SM's with NAT enabled and a shared NAT/MGMT IP do not automatically get entered into oboard queue

AP/SM firmware 15.0.1, using the cloud based cnMaestro

Title says it all... We have many many SM's that have NAT enabled, and have a shared NAT and management IP. The DNS entries are correct. When we add an AP to cnMaestro, all the SM's are supposed to be automatically sent to cnMaestro onboard queue.... but they don't... only SM's that have bridging enabled for static IP customers.

My guess is that there's a bug where the cnMaestro agent on the SM is trying to use the DNS fields out of the IP tab... but nothing is entered in there because NAT is enabled, and it's not using the DNS settings on the NAT tab.

SM's with NAT enabled show:

Resolving URL ( - Default Cloud URL)

Can I get some help on this please?

Confirmed on 15.0.2. If the remote config interface is set to Disabled or Use WAN, then the SM itself cannot resolve any DNS. The easy solution is probably to use the LAN DHCP DNS servers defined (or obtained via DHCP from the WAN) when the remote config interface is set to Use WAN. But we use standalone mode which obviously works.


We are aware of this bug (CPY-12710) and it will be addressed in the next release (15.1). We will post the beta in a few weeks.