splash page not coming up on laptop

We have a hotspot with a couple units in use, and working, on cell phones.

My problem is some laptops (like my own using Ubuntu) don't seem to show the splash page when loggin in to the network. Mainly, it seems I need to pick a particular page to get it to load. Like google.com, msn.com don't work. But, if I try to login to the main router connected to these hotspot AP's it shows. Or even our own company webpage. I'm (assuming) this is because some pages like google and msn automatically change to https. And not http.. Is this where the setting in the cnmaestro to select http only redirect would come in? I have that unchecked though and I would think it would work properly.

This is of course causing an issue with other laptops in this RV park.. Would I also "have to" add a URL to redirect to for redirection to work.. Or should the default make this work as one would think...? 


1 Like

Browsers these days have inbuilt security which for many sites automatically upgrade them to HTTPS which you are seeing with google and msn. They don't even allow you to make a HTTP request for these domains. You should enable "http redirect only" in the WLAN guest-access configuration and you need not configure "" or any other URL there. This "redirect http only" config will help in some cases where the browser would automatically downgrade HTTPS requests to HTTP when it doesn't get any response over HTTPS. Such limitations exists for a captive portal and typically many OS have now inbuilt captive portal detection mechanism which opens a sign up window for captive portal splash page.

I will check out if google chrome on ubuntu has some auto detection methods which may help user notify that a login is required to get to Internet.

1 Like

We have the same issue.

When client is a first time visitor guest portal most of the times appears and can log in.

When the session expires (12h/12h) Guest Portal does not appear or alert user that he needs to log in.

The client device "thinks" it have the privilage to use internet acces without the need to log in again. So it does not even try to find the guest portal again, it just tries to load the original webpage and keeps trying forever.

Settings are on the default:

Enabled HTTP-only Enable redirection for HTTP packets only
Redirect User Page:
Had this issue tested with android, and ios. Chrome, Safari, samung browser. On different phone brands: Samsung, Sony, and some others. Received reports from other users having the same issue.
Redirect to guest portal could be triggered the following ways:
#1 Write a never before used URL (works but not always)
#2 For some reason each phone had their own pefered often used website which it worked with but different on each phone. (for example www.index.hu other phone www.hvg.hu)
#3 Write neverssl.com (works all the time)
#4 remove "s" from https
#5 write the IP of the gateway.