SSL Import error on 2.4.1-r10 on premise

We are in the process of spinning up a new VM array, and are migrating a cnMaestro deployment over to it. I was able to get the machine started and imported our backup from the other machine, but I cannot get the SSL certificate installed.

I have tried uploading our original PEM file (key, domain wildcard cert, and supporting intermediate certs) and that fails. I then exported the cert from a working maestro server and tried importing and it fails as well. Both give me an error “not a valid certificate chain” while trying to import into the new deployment. Any help getting them to work would be greatly appreciated.

Hi Nicholas,

Sorry for the inconvenience caused to you.
Certificate exports are not part of Data Backup and Restore, this is mentioned in known issues.

If your old server is still exist where the SSL is working, please power it on and take the backup of SSL certificate under the section, Application==>Server==>SSL certificate==>Backup.
Import this file in the new server by selecting “Import Signed Certificate and New Key”.

Thanks for your response, however I have already tried to backup the cert and re-import it as stated in my original post.

The following keys all give the same error:

  • The original certificate PEM file as provided by our SSL CA
  • The backup certificate from our primary and fully operational instance
  • The backup certificate from our testing instance (That this VM is replacing on a new system)

Hi Nicholas,

Can you please check your mail box and respond to it.