template won't apply protocol filter for "All IPv6"

I set up a golden config for our APs using the config file from a new AP.  On the AP->config->protocol filtering, I checked the box for "All IPv6" which also checks and the greys out all the other IPv6 settings.  I then exported the config file and imported it as a template in cnMaestro to apply to all our APs.  attached below is the section of the template.  once I apply the template to another AP there is nothing checked in the IPv6 section.  I also tried changing the template so that all the IPv6 parameters=1 but that stopped all traffic to the SM including IPv4 traffic.

"networkConfig": {
"webAutoUpdate": 5,
"lldpBroadcastEnable": 0,
"poeAuxEnable": 0,
"ethernetLinkSpeed": 12,
"packetFilterSmb": 1,
"snmpStatus": 1,
"lanDhcpState": 0,
"packetFilterUser1": 0,
"dnsPrimaryMgmtIP": "",
"packetFilterOtherIpv4": 0,
"enable8023linkBox": 1,
"bridgeEntryTimeout": 25,
"auxPortEnable": 0,
"dnsAlternateMgmtIP": "",
"dnsIpState": 1,
"portFiltering": [],
"tftpStatus": 1,
"packetFilterBootpServer": 1,
"telnetStatus": 1,
"dnsMgmtDomainName": "zirkelwireless.com",
"sessionTimeout": 600,
"localNTPServer": 1,
"webAccess": 0,
"defaultIPAccessEnable": 0,
"packetFilterBootpClientIpv6": 0,
"ftpPort": 21,
"httpPort": 80,
"enableSecurityBanner": 0,
"httpsPort": 443,
"packetFilterMulticastIpv6": 0,
"packetFilterAllIpv6Others": 0,
"ftpStatus": 1,
"poeT2Classification": 0,
"textSecurityBanner": "zirkelwireless.com",
"acceptSecurityBanner": 1,
"packetFilterSnmp": 0,
"packetFilterPppoe": 0,
"packetFilterArp": 0,
"packetFilterUser3": 0,
"packetFilterSmbIpv6": 0,
"packetFilterAllIpv4": 0,
"packetFilterSnmpIpv6": 0,
"packetFilterUser2": 0,
"packetFilterAllIpv6": 1,
"packetFilterAllOthers": 0,
"packetFilterBootpClient": 1,
"packetFilterMulticastIpv4": 0,
"packetFilterBootpServerIpv6": 0,
"packetFilterDirection": 3,

1 Like

also "packetFilterSmbIpv6": 1, doesn't check the box for "SMB IPv6"

Sean, Thanks for bringing it to our attention.

We will fix it in a future release.

1 Like


fyi, all the IPv6 knobs don't seem to work via config file/template.  they do seem to work if you manually change them though.

Thanks, Sean!

We are aware of this issue. We will fix it along with the other issues you have reported.

also on the SM side a cnMaestro template doesn't seem to be able to change any of the protocol filtering options.

I'm going to jump on this train as I got the boxes to all check, and visually it looks correct when applied with a config template, but the customer cannot pass traffic.

Here's the config chunk:

"packetFilterSmb": 1,
"packetFilterSnmpIpv6": 1,
"packetFilterBootpServer": 1,
"packetFilterBootpClientIpv6": 1,
"packetFilterMulticastIpv6": 1,
"packetFilterAllIpv6Others": 1,
"packetFilterSnmp": 1,
"packetFilterSmbIpv6": 1,
"packetFilterAllIpv6": 1,
"packetFilterMulticastIpv4": 1,
"packetFilterBootpServerIpv6": 1,
"packetFilterDirection": 1,

We are not using IPV6, but just don't want any chatter if a customer is on their end. If we apply with the config it doesn't pass traffic. If we then uncheck all the boxes, reboot, check the boxes manually, reboot it works fine. Seems there is a bug when trying to apply via config.

This is using 15.1.5

Is there an official way to report this bug?