обновление прошивки

Добрый день,

имеется сеть состоящая из 

CMM

Software Version: CANOPY CMM 2.2 Build 2b Jan 16 2007   16:23:29
PLD Version:      5

AP

Software Version : CANOPY 8.1.4 AP-DES
Software Boot Version : CANOPYBOOT 1.0 FPGA Version : 102606 PLD Version : 9 Frequency Band : 2.4GHz Hardware Platform : 10 Hardware Minor Revision : 0
Software Version : CANOPY 7.2.9 Jul 23 2005   01:49:03 AP-DES
Software Boot Version : CANOPYBOOT 3.0
FPGA Version : 070605
FPGA Features : Single,  40MHz ExtBus, DES,  Sched
Frequency Band : 2.4GHz
Hardware Platform : 9
Hardware Minor Revision : 0

SM

Software Version : CANOPY 10.5 SM-DES
Software Boot Version : CANOPYBOOT 1.0
FPGA Version : 111010
PLD Version : 11
Frequency Band : 2.4GHz
Hardware Platform : 10
Hardware Minor Revision : 0
Device Type : CANOPY
Software Version : CANOPY 9.4.2 SM-DES
Software Boot Version : CANOPYBOOT 1.0
FPGA Version : 061808
PLD Version : 11
Frequency Band : 2.4GHz
Hardware Platform : 10
Hardware Minor Revision : 0
Device Type : CANOPY

 и т.д.

хотелось бы обновить версии прошивок до максимально возможных, но при это не потерять работоспособность сети. Оборудование смотнтированно в труднодоступной местности и достаточно давно, обновлений не производилось. Возможен ли вариант апгрейда сразу на последнии версии, или предварительно необходимо будет произвести последовательный апгрейд на версию выше? Если в случае неудачного апгрейде SM модуля есть возможность его оперативной замены, то в случае CMM и AP такой возможности нет.

Для старых версий софта (7.х, 8.х) может потребоваться многоступенчатая процедура апгрейда. Я соберу информацию по рекомендованному порядку, а вы соберите полный перечень версий ПО в сети.

список ПО в сети

CANOPY CMM 2.2

CANOPY CMM 3.1

Cambium Canopy 9.5 BH20-DES

Cambium Canopy 7.2.9

Cambium Canopy 8.1.4 AP-DES

Cambium Canopy 8.2.4 AP-DES

Cambium Canopy 8.2.4 SM-DES

Cambium Canopy 9.4 AP-DES

Cambium Canopy 9.4.2 SM-DES

Cambium Canopy 9.4.2 AP-DES

Cambium Canopy 9.5 SM-DES

Cambium Canopy 10.3.2 SM-DES

Cambium Canopy 10.5 SM-DES

Cambium Canopy 11.0.1 SM-DES

Cambium Canopy 11.1 AP-DES

Cambium Canopy 11.1 SM-DES

Cambium Canopy 11.2 SM-DES

Cambium Canopy 11.2 AP-DES

Я поднял старую документацию, официальный (протестированный и рекомендуемый) путь такой:

7.3.6 -> 8.2.7 -> 9.0 -> 9.4.2 -> 9.5 -> 10.3.2 -> 10.5 -> 11.2 –> 12.1 ->  13.х

Здесь лежит относительно новый софт:

https://support.cambiumnetworks.com/files/pmp100/archive

Здесь я собрал старый софт:

https://yadi.sk/d/HK_v2A74fn5Mp

Не хватает 9.4.2. Но допустимо с 9.0 сразу прыгнуть на 9.5, такой путь тоже тестировался.

Для заливки PKG вам потребуется CNUT1, PKG2 - CNUT2, лежат там же.

Спасибо за столь развернутый ответ.

Есть еще несколько вопросов связанных с прошивкой:

1.Какова последователльность прошики модулей? Например сначала шьем CMM до последней версии, потом BH, AP и SM.

2.Какой вариант прошивки предпочтительней, по радио каналу или со стороны eth интерфейса? Для меня по радио предпочтительней, иначе придется людей посылать на удаленные объекты.

3.После прошивки не теряеются ли настройки оборудования?

  1. Обычно при обновлении софта из центра, начинают с удаленных абонентов и двигаются к центру сети. Но у вас в сети реальный зоопарк, поэтому я бы сначала подтянул AP 7.x.x до своих абонентов - 9.4.2, а потом бы продолжил в таком порядке: SM - AP - BH - CMM.
    2. По радио можно.
    3. Не должны.

Спасибо!

Добрый день!

При обновлении Canoy SM выдает ошибки:

No master/slave register link detected.

Error Connecting to device via telnet interface!!

 и не обновляется.

ПОдскажите пожалуйст в чем может быть проблема.

Error Connecting to device via telnet interface!!

доступ по telnet проверьте.