Unable to allocate a /16 (anything that's not a /24 really) Ip Pool for DHCP

Hi, i noticed a low connection count at a HotSpot i'm experimenting with.
It uses Cambium's integrated DHCP+NAT

My original configuration, made manually, was as follows:
!
interface vlan 171
ip nat inside
management-access all
ip address 172.17.0.1 255.255.0.0
!
ntp server 200.20.186.75
ntp server 200.20.186.76
ip dhcp pool 7
address-range 172.17.0.10 172.17.255.245
default-router 172.17.0.1
dns-server 172.17.0.1
lease 33 22 11
network 172.17.0.0 255.255.0.0
!

The web interface showed a Pool-size of 235, so obviouslly something was assuming a /24 and subtracting 10-245 == 235.
I never saw any DHCP allocations to anything other than 172.17.0.X
Ignore the lease time, it's there for debbuging purposes. I was trying to force an exhaustion, to see what the logs would say. Unfortunatelly, not enough people passing by to trigger that.

So i decided to create an AP-Group / SSID and Site at Cnmaestro, and pushed that to the AP.

!
interface vlan 171
ip nat inside
no management-access
ip address 172.17.0.1 255.255.0.0
!
ntp server 200.20.186.75
ntp server 200.20.186.76
ip dhcp pool 7
address-range 172.217.1.1 172.217.218.219
default-router 172.217.0.1
dns-server 172.217.0.1
network 172.217.0.0 255.255.0.0
!
The pool never comes up, pool 7 shows as NA, and pool 1 (not existent), shows as DOWN.

Is this a known deficciency, or a bug, or i'm grossly misinterpreting the way the config should be done?

off course i don't need a /16 in the interface, the original production config was a /22 with 1 hour lease, or should have been....

Could anyone be kind and share a working config section for a non /24 Pool, so i can see what i'm doing wrong?

Hardware is an E700, firmware 3.11.2, rebooted between config changes to make sure interfaces were reloaded.

Your second config snippet has a typo in the second octet of the address - the IP address for vlan 171 is 172.17.0.1 while the DHCP pool is in 172.217.0.0/16 . The DHCP server needs the AP to have an IP address in the same subnet as the pool since some of the DHCP messages are subnet broadcasts. As they don't match, the DHCP server will be unable to use that pool. Once you fix that the pool should become available.

2 Likes

Indeed... the WAN address is in the 10.217 range, so.... 

fixed that and the Pool got correctly bound to the interface.

Still, both Maestro and Web management shows a pool size of "218"

A day later:
So, whatever is causing the low usage in the hotspot site is not DHCP.
With a big lease time, i managed to get allocations across the whole subnet, which is good :-)
(pool goes from 172.17.111.111 --> 172.17.222.222)
Client [28-83-35-A6-B7-FB], assigned [dynamic] IP [172.17.112.59] from DHCP pool [7]

The "pool size" is probably a cosmetic issue in the GUI. At boot time, with said config, the reported "pool size" was of 111 addresses. Right now we're in negative territory, so the UI can't even render..