Update from 4.x to 4.2.3 to 6.1 to 7.1 - BH-10 Do Not Reboot


I followed the documentation found in the .pdf in each version:


put 062403_D40.jbc
put BH10boot.bin
put block.bin
jbi -aprogram 062403_D40.jbc

Result: It worked.

6.1: Used CNUT

enable 6.1 image
updade selected

Result: It worked.

7.1: Used CNUT

enable 7.1 image
updade selected

Result: It worked.

Doing the same for the other BHB-10…


Result: It worked.


I clicked refresh in CNUT then CNUT started updated to 7.1 without checking for 6.1… then the AP resetted and … (crap)

Result: The SYN/SES/GPS LEDs blink one after the other and the Ethernet port dont come back up.

Is the serial port usable to fix this obvious firmware problem?

And How come CNUT didnt ask if I wanna update the firmware and decided to do it by himself … thus making a expensive paper weight out of the BH-10.

Thanks for the help.

We had a similar, unfortunate problem with an upgrade. We like the Canopy product, works great. But after one expensive disaster some time back we stopped all updates. No more, just leave it the way it is from the factory. Some people may not be able to get by without updates but so far we haven’t found a need to make any changes.


I found that support personel are not very creative and is always re-hashing the same thing. I hate when Motorola assume they are dealing with clueless clients.

They should have a bootrom on a serial device with a simple xmodem to upload firmware in those cases. Of have a backup serial-flash and a seconday flash that is enabled when the default plug is inserted. A cost of about $10/100ma per device.

We know that it takes 1 hour to re-flash those devices and are working into getting in contact with ex-personel of Motorola and a JTag bench to re-flash that device with the firmware from the working one. If we’re successfull I’ll post the technical info how to do this.

Thank you very much for the response. I’ll make certain our Motorola Canopy “brick” stays in my desk in case the opportunity for a second life comes along. Thanks again,

Has there been any progress on this front? I have a brick of my own as well.

are you using a default plug to try and log into the box after its crashed?

also make sure you are trying to access it using the default canopy ip which is

I have never killed a box doing upgrades…i was always able to reflash them through the

Here’s a little tip, when going from a 4.x to a 7.x. Upgrade to the proper 6.x, do not do multiple upgrades at the same time with CNUT. Do 7.x after you have confirmed that the AP and SM’s have came back up. This way if there was a problem with the 6.x or 6.x did not finish the auto update SM’s, which can take some time, you will not have a locked up AP or Backhaul.

Try using the default plug and redo the 6.x firmware, then go to 7.x.