# Upgrade with CNS

**URL:** https://community.cambiumnetworks.com/t/upgrade-with-cns/38339
**Category:** ePMP
**Created:** [September 22, 2014, 12:39pm UTC](https://community.cambiumnetworks.com/t/upgrade-with-cns/38339 "2014-09-22T12:39:25Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![tiagoghisi](https://d10gw3vjmzyp8.cloudfront.net/letter_avatar_proxy/v4/letter/t/bc79bd/32.png) [@tiagoghisi](https://community.cambiumnetworks.com/u/tiagoghisi)
#### Post date: [September 22, 2014, 12:39pm UTC](https://community.cambiumnetworks.com/t/upgrade-with-cns/38339/1 "2014-09-22T12:39:25Z")

</div>

I, i cannout upgrade any ePMP with the CNS, i reinstall a CNS the new server, with the centos x64, 6.5 and CNS (Version 1.2.19.2979)  
  
Any upgrade fails, and the only error is   
  
Device Name   
Device Type ePMP\_STA  
Device ID 00:04:56:C0:0F:DA  
Device IP Address 10.20.100.26  
Event Description Failed to upgrade device to Version 2.0.0  
  
upgrader.log  
  
2014-09-22 15:00:12,285 ERROR UpgradeMonitorThread.run(): 00:04:56:C0:0F:DA: Failed to upgrade device to Version 2.0.0

---

<div class="post-metadata">

### Author: ![Jordan](https://d10gw3vjmzyp8.cloudfront.net/letter_avatar_proxy/v4/letter/j/eb9ed0/32.png) [@Jordan](https://community.cambiumnetworks.com/u/Jordan)
#### Post date: [September 22, 2014, 3:11pm UTC](https://community.cambiumnetworks.com/t/upgrade-with-cns/38339/2 "2014-09-22T15:11:12Z")

</div>

This error is typically displayed when CNS cannot confirm that the device was upgraded to a specific version during the verification step when it queries the version currently running on the device. There are a few things you can try.  
  
Verify that the SNMP and Login/Password credentials are correct in Discover -\> Inventory. Use the verification tool to ensure that they are correct with right-click -\> Verify Credentials. They should turn green after the test.  
  
Enable SNMP Traps on the devices and point them to CNS. CNS will see upgrade related traps and show them in the Events view, which will help debugging.  
  
  
The device may also be in a error state where it won’t accept an upgrade, even when performed in the device web UI. Try rebooting a single device and attempt to upgrade it again to see if this is the problem.

---

<div class="post-metadata">

### Author: ![tiagoghisi](https://d10gw3vjmzyp8.cloudfront.net/letter_avatar_proxy/v4/letter/t/bc79bd/32.png) [@tiagoghisi](https://community.cambiumnetworks.com/u/tiagoghisi)
#### Post date: [September 23, 2014, 6:14am UTC](https://community.cambiumnetworks.com/t/upgrade-with-cns/38339/3 "2014-09-23T06:14:44Z")

</div>

Jordan  
  
The credentials is ok, now i active snmp traps and recivied this message "Upgrade failed. Failed to download upgrade package."  
  
Firewall the CNS is disable.

---

<div class="post-metadata">

### Author: ![Jordan](https://d10gw3vjmzyp8.cloudfront.net/letter_avatar_proxy/v4/letter/j/eb9ed0/32.png) [@Jordan](https://community.cambiumnetworks.com/u/Jordan)
#### Post date: [September 23, 2014, 9:47am UTC](https://community.cambiumnetworks.com/t/upgrade-with-cns/38339/4 "2014-09-23T09:47:48Z")

</div>

Tiago,  
  
The devices may be using the wrong IP address to download the upgrade package from CNS.  
  
Does the machine that CNS is running on have multiple NICs? Is it behind a NAT? Either of these things could cause CNS to point devices to an IP address that is not visible to them.  
  
There are two administrator options to handle this in Admin -\> General.  
  
“Network Facing Interface” should be updated if you are using a multi-NIC machine.  
  
“Device Accessible IP Address” should be updated if CNS is behind a NAT.

---

<div class="post-metadata">

### Author: ![tiagoghisi](https://d10gw3vjmzyp8.cloudfront.net/letter_avatar_proxy/v4/letter/t/bc79bd/32.png) [@tiagoghisi](https://community.cambiumnetworks.com/u/tiagoghisi)
#### Post date: [September 23, 2014, 10:53am UTC](https://community.cambiumnetworks.com/t/upgrade-with-cns/38339/5 "2014-09-23T10:53:00Z")

</div>

Hi  
  
Jordan  
  
yes, have two NIC  
  
I fixed it and work perfect  
  
Tks  
  
Regards
