Upgrading SM from 4.1.3

I’ve got an SM in the field which I am attempting to upgrade to 4.2.3 to that we can use CNUT to upgrade it to 7.3.6. I managed to recover a copy of the 4.2.3 firmware, and am able to ftp the SMboot.bin file to the SM, but when I run the “burnfile” command from a telnet prompt, I recieve the following error message:
Validating Boot File…
fread() file ReadSize failure
File:SMboot.bin is not a valid image file
Can anyone help? My thought was that the bin file is corrupt, if it is, where do I get a new copy? It is no longer available on the Moto website, and I couldn’t find it anywhere else. Or perhaps there is another reason it’s not working?

Pkg files could be extracted with winrar for example. You could try upgrading it with 6.1 software.

PM me your e-mail address and I will send you the version of the firmware you need.

I have all versions of firmware back to 3.0.

Don’t forget that you can’t go from v4 straight to ver 7.3.6, you have to go to 7.2.9 first…

I was able to WinRAR the 7.2.9 package and update the old SMs and APs via ftp/telnet. Thanks again!

How was this done? I have 4 radios that will just not update past 7.0.7 and I would like to try doing it mannually before I do a roll out. It gives a couple of reasons but usually it fails saying that the SMBoot.bin is not a valid image file or Lock Main failed!

I have tried 7.2.9 and 7.3.6 neither will work with the latest versions of CNUT. I might try to go to 8.x but Im sure that will fail as well.