Various Serious issues with 6.1 software and Canopy

I have various issues with canopy at this time. i have deployed 2.4, 5.2, 5.7, 900mhz. i have deployed BH, APs, SMs in every available configuration over a wide variety of locations, terrains and noise levels.

Our first serious Canopy issue was with a 2.4 system and very slow download and upload performance. Radio reports 100% uplink and downlink efficiency and gets no more than 500k BITS not Bytes on some to a max high of 1.4 meg (very very rare) Not all users are of course 100% up and down but some of the those that are get only 500k. Number of users doesn’t make a difference we have tested from 1 to 25 users and get the exact same results. Activity on APs does not make a difference. Distance does not seem to make a difference either.


i know how to run speed tests both local LAN and internet. WE have files we transfer from local servers and use any number of internet speed sites. i make sure there is plenty of available bandwidth before testing. there is plenty of bandwidth at that tower. Tower site = 4 meg available at same time using same/multiple test sites. Tower site fast, SMs very slow

Transmit Frame Spreading = OFF. Since Support is always looking for excuses, TFS is off. Performance stays the same.

Motorola’s help in this issue = totally non existent. I was told I am the only person to EVER have this issue and NO ONE else has EVER reported speed issues. So if anyone else out there has EVER called in with a 2.4 Canopy speed related issue, Canopy Support says you are a liar because they told me i am the ONLY one.

Next major issue in timeline - Upgrade 3 APs to 6.1. Called support prior to make sure that the CNUT would work with downgrading radios if there was a problem with 6.1. They said yes.

First to upgrade was the 2.4 Canopy APs with the speed issues. Hey maybe it will fix the speed issues. NOT. Speeds get worse, performance goes to hell. All customers that were at the lower signal levels disconnected.
Canopy support says I am the ONLY one having or ever having this or any other problem with 6.1 software.

Since I had not YET noticed the problem with the 2.4, we moved to the 5.7s that have almost always been flawless. Upgraded about 25 clients and 1 AP and surprise surprise customers start complaining about speed issues within 2 hours of upgrade. Canopy support says i am the ONLY one having any issues with the 6.1 software.

Well that was enough for us we decided to go back to 4.23 that was so much more stable etc. AP takes the 4.23 firmware from 6.1 just fine. Subs will not take the downgrade. Ap will not autoupdate down to 4.23 as Canopy support says it would. Canopy support says I am the ONLY one having any issues with the 6.1 software being downgraded to 4.23. I guess why downgrade since no one else ever had a problem with the 6.1 software.

Latest/NEW issue - 900mhz Deployment. (pulling down 2.4 that would never get up to speed and replacing with NLOS 900mhz and 5.8 WITH 4.23 firmware of course)
These are 6.1 Canopy Advantage APs. First test very close to tower using connectorized Canopy AP with HPOL OMNI. 2800 RSSI with jitter of 1 and it won’t register in 10, 20 30 attempts sometimes. Once registered it boots the connection over and over after a few minutes each time. We figure must be defective AP. Move to integrated 900mhz canopy unit and new SM as well as first tested SM. Same results exactly. Speeds great at 1.7 meg consistent WHEN and for as long as it stays connected. Latency is horrible at 15 (very rare) to 135 ms averaging around 80ms. Call Motorola and NOW I am the ONLY one that has had this issue. They say it must be transmit frame spreading needed issue. We change SMS and Aps to software scheduling. SMS no longer get booted. They register IMMEDIATELY on the FIRST attempt every time. Jitter always less than 4, signal around 1500 on 2 installed test sites. no booting in 13 hours. Rock solid links that do not drop. Latency goes to the 40ms as Motorola claims with 900mhz in SS mode. Very steady latency. However now the speeds are down to a max of 700 (very rare) and run from 350k to 500k only with both SM and AP set to max up/down/burst etc. Motorola says it’s the Transmit frame spreading keeping the links up since hardware scheduling does not have TFS that’s the issue. TFS is and remains off and has been off. ROCK solid links, 40ms latency and very slow speeds in Software schedule mode without transmit frame spreading. Oh should I mention that Motorola support says i am the only one with any hardware scheduling issues on the 900, the only one with any problems on the Advantage platform and the ONLY one with latency issues on the 900.

So to sum it up. I am the only one that has any problems with latency, speeds, holding links or any other issue with anything in the Canopy Product line EVER. So the question is, why do they even have tech support if I am the only one calling it? (yes it’s real)

Although I have not experienced the issues that you are currently experiecing, I agree that I have been disappointed with Motorola’s Tech Support since we started using Canopy two years ago. Every single time I have called them, I have always ended up answering my own questions by listening to myself as I explain my problem to them, and hearing nothing but “uhhhh, hold on while I check on that for you sir” - Begin holding for 10 minutes… When they don’t put you on hold, all they do is pull up the Product PDF’s and read back what it says to you.

Now to your specific problems. I upgraded all network nodes (all NON-ADVANTAGE) from 4.2.1 to 6.1 about two weeks ago and everything has worked flawless. When upgrading one of our Access Points, CNUT locked up and the BOOT VERSION 3.0 was never successfully transferred and burned into the AP. When I tried to upgrade it again, it would not allow me because it detected that the “actual” 6.1 firmware was in there, although it did not contain the proper BOOT VERSION. I thought about it for a moment and figured that the only way to get around that would be to downgrade to 4.2.1, then attempt an upgrade to 6.1 again. Fortunately, this worked.

Note that I was using the old version of CNUT, the one that was released back in March/April of 2004. I DID NOT D/L the new version which contains the “special update” feature to be used on networks utilizing ADVANTAGE APs. I did not download this because we have all NON-ADVANTAGE products. I spoke to Motorola ahead of time via e-mail and was told that the old version of CNUT would be fine for what I was going to do. Which version of CNUT did you use to upgrade to 6.1?

You say that you experienced your first set of problems on a 2.4 Canopy system. You say that radio links reported 100% up and down but speeds were slow. I share this exact same experience with you in 5.8. The problem ended up being interference. Like I said, the Link Test showed 100% up and down links, but speed tests because progressivly worse, and pings from within the network could get as high as 200ms, and as high as 2000ms from the net. At this point in time, the network was running firmware 4.2.1. As soon as we changed the frequency of the AP and SM’s on that AP, everything went back to normal. The point is that the Links Test showed 100%.

Just some of my experience. It seems odd to me that all of your modules are experiencing problems. At this point it either seems like intereference, or you have a bunch of bad modules. How long was it before all these problems started happening?

What reasons did you call tech support for? I was told I was the only one to ever report a speed, latency, or any other problem with Canopy!

We used the latest and greatest version of the CNUT that was available on the web site.

have you tested your network for speed since going to 6.1? i have a lot of tech/geeks so if we have issues we hear about them very quickly. And actually we have quite a few sites and APs without issues. Only the 6.1 APs are having issues.

And the 900MHZ system is all kinds of screwed up. hardware scheduling gives us 1.7 meg but the links drop every few minutes and take at least 5 minutes to come back. 50% downtime. Fast however. pings average 80 to 125ms with hardware scheduling. Go to software and the links are rock solid but the speeds suck at 350 to 500 …latency however gets down to 40.

My guess is the Advantage system on 900mhz with hardware scheduling has major issues. I would be very suprised if Motorola didn’t know about it when they released it and they just deny it. IF we can’t link to a tower with 2800 rssi and a jitter of 1 while pointing 2 12 db integrated units at each other from tower to ground, my guess is they might just be buggy. We tried 2 aps and now 5 different Sms all with same results.