Vlans configuration

Hi all

I am trying to set up vlans on my canopy network, but i seems I am doing something wrong because I can’t get it to work…

I am using soft. ver. 7.3.6, running hardware scheduling.
I am doing a lab with 1 ap and 2 sm’s; and when I enable the vlan option on the AP …I can ping the SM’s but not the computers behind those sm’s.
and the computers behind the SM’s can not even ping the SM that is conected to them with a cable…it is weird.

I have the SM’s configured to add the VLAN id to the untagged packages coming into the wired interface but it doesn’t seem to be working.

Any thoughts…???

Everytime you talk to the SM either via the AP or via the SM you are talking the Management interface on the deveices.

What is your ingress VID on the SM
what is you Management ID on the SM

Once you enable the VID on the SM, locally connected machine will not be able to talk to the SM, because by default the MVID will be 1 and your packets will get tagged with the Ingress VID you have set in the SM configuration, i.e SM and AP are VID 1 and say your ingress VID is set to 10, they your PC’s are on VID 10.

If you want the PC to talk to the SM you have to get a VLAN enabled NIC and set the VID to 10 and then set the SM to allow all tagged packets.

In your setup you should be able to get two machines connected to the 2 SM’s to talk to eachother.

Hope this is sufficient… if not post again for clarification…

You might also want to check the configuration source option on the AP, by default it is set at BAM, change it to SM. On the AP set the vlans you are using on the Vlan Membership page. On the SM leave the managment id at 1 and set the untagged to what you need. As VJ said it will allow the two SMs to talk only to each other. If they need to talk to another AP or get internet access, make sure you are using a switch that can support vlan tagging, like Cisco.

I will try it again tonight using a Cisco switch to see if it passes the frames thru.
I will let you know tomorrow…