Web Interface on 900Mhz AP stops working

As stated in an earlier thread I recently bought a 900Mhz Canopy demo kit.

I have had it two days now in the office and have the basics worked out. That is, I have the AP etherneted to my LAN at one end of the office and an SM connected to a laptop at the other end. From the laptop I can access everything I would expect to. It works good.

Telnet+> version
Software Version : CANOPY 7.2.9 Jul 23 2005 01:49:03 AP-DES
Software Boot Version : CANOPYBOOT 3.0
FPGA Version : 020205
FPGA Features : Single, 40MHz ExtBus, DES,
Frequency Band : 900MHz
Hardware Platform : 9
Hardware Minor Revision : 0

I have, for ease of testing/learning, assigned a public IP to all interfaces involved and can access the AP or SM from anywere. However, the Web Interface on the AP stops responding after about 20 minutes (can not even access the AP web interface via the SM after about 20 minutes). EVERYTHING else works fine. The SM/AP can still pass traffic, I can still telnet into the AP from anywere “everything” works just fine other than I can not http into the AP (I can still access the web interface on the SM from anywere).

I can be on the AP web page, as I am reading the manual, and clicking on this or that as it is mentioned in the manual and suddenly “page can not be displayed”. Yesterday I left to do something else for several hours and when I returned I still could not bring up the web page from any system on the network. After I reset the AP , I could access the web page agian, for about 20 mins then I lost it again.

As I set here at home reading the manual, over the last hour I could telnet into the AP and reset the AP when the web page would stop working. Once reset via telnet then the web interface would work agian (for about 20 minutes). However, as I write this, the web interface went down again and this time it isn’t working. I have reset it 3 times now and still no http.

Woops, 4th time worked. I can http in again.

At first, while at the office yesterday and today I wondered if it was some sort of security feature (web inteface bad, but we will let you have access to it for 20 minutes after reboot). Espically since setting a password appears to only affect Telnet. That is, even though I have read only and full access passwords set, the web interface never asks me for a password, only when I telnet in am I required to enter the root / password.

I am going through the manual ( all 498 pages of it ) reading the relevent parts. While my problem may be covered in the manual , I have not run into it yet. There was mention in there about problems accessing the web interface when using a proxy, however I am not using a proxy on any systems and I lose access to the page on all systems , even the laptop with the SM attached to it.

The 20 minutes could be off , it could be more than 20 mintues. I tend to lose track of time when I am pooring over a manual.

Again, thanks in advance for any info / help on this.

Farrell

It appears the time is random. After posting the above, and rebooting several times to get the web interface back up it only stayed up about 5 minutes before it stopped working again.

Farrell

It is a known flaw in that version of software when using public IP addresses. You are doing nothing wrong. If you’re just lab testing try upgrading the software to 8.0.

2 things:

1. Like the others have mentioned, if you use a public IP, then your device will get overloaded with internet crap (pings, etc…) and that will cause you to lose the web interface.


2. This happened to me with PRIVATE IP addresses. It seemed like every 20 minutes or so I couldn’t log back into the web interface of my SMs. Set your “Bridge Entry Timeout” to something HIGHER than the ARP timeout in the router that feeds the network. If you want to make it the max (1440), so be it, but that should fix the problem.


Let us know what happens.

Sorry I didn’t get back with a " Thanks " sooner. I ran into another issue and got side tracked.

I appreciate the info. I am going to change over to private range, thanks to the info you all provided, and see if it solves this and a couple of other weird problems.