WirelessManager Not Loading Google Map

The Wireless Manager clients starts correctly, and other commands and features work as normal, but when I attempt to load the online map, it connects to a server but then does not load any map pieces.

Has the change to the new Google Maps caused a problem ?

Is there a cache I need to clear in the client ?

Side note, is there a way to have the client or server report which service pack is installed ?
My client reports 4.0.12 without any mention of service pack number.

Thanks for any help,

Charles Dostale
Cedar Falls Utilities
Using 430 APs and SMs and a PTP800

I am having this very issue as well.
I hope that google maps did not change something.
Any ideas on this Cambium?


You’ll need to upgrade Wireless Manager to service pack 4. If all you are seeing in the about window is 4.0.12 then none of the service packs have been installed. You’ll have to install each of the services packs in order to bring your server up to service pack 4.

Google retired the v2 Javascript API libraries we use back in November. In order to support the v3 APIs we introduced updates beginning with service pack 3.

Service packs 1-4 can be obtained from the download site at http://www.cambiumnetworks.com/support/ … ss-manager.


This worked for me.
Thanks Much

For my question about finding the Service Pack version, I found a way in the Admin Guide.
Sorry, I am a Linux CLI guy, so some may need to read man pages to follow along.

Find the latest log file :

 ls -ltr /usr/local/cambium/wm/server/logs/wmsout*|awk ‘{print $9}’|tail -1

Find the log entry that says what Service Pack is installed :
cat /usr/local/cambium/wm/server/logs/wmsout94.txt |grep “Service Pack”
Service Pack Version =NONE

I am working on stepping through the Service Pack upgrades to see if that solves my issue.
I had downloaded SP1 and SP2, I keep getting " Service Unavailable " when attempting to download SP3 and SP4.

I had to run " ServerAdminTool.sh " from a shell as the root user, I could not use " sudo " to run the command. I was able to upgrade to SP2.

I’ll have to check back to the Cambium web site later to see if they have fixed the file download issue.

The easiest way I have found to get these updates in without issue is to have a
desktop on top of the server. Like Gnome or KDE. Something really basic.

I am definately a CLI guy to but when the application runs smoother with its gui then
Ill make use of it.

Note: You must turn off WM server before doing this!

Just open a terminal on the desktop and be sure you are root by > su <password>
Then run /usr/local/cambium/wm/server/bin/./UpdateManager.sh
Once it loads you should be able to see what current packages are loaded and select the
next up one level and install. Do this until you reach version 4 and all will be right with
the world :slight_smile:

There’s a way to install SPs via the CLI? Holy crap.

My Prizm and WM servers are the only Linux boxen I have with GUIs just for the stupid management interfaces.

The Update Manager is a java gui thats y I prefer to have the desktop to help with the java gui.

Yes, I run a Gnome desktop on the WM server, but I prefer to use CLI when I can. That’s how I grew up 8)

My comment was about starting the ServerManager and UpgradeManager tools. I DO NOT EVER run a Linux GUI desktop as root. If I need to run a command with higher priviledges, I use " sudo " from a Terminal, or at last resort " su " to root, which is what I had to do for the Cambium utilities.

The upgrade to SP3 fixed the issue I was seeing. I also then upgraded to SP4.

With the change in Google API, it appears you can no longer type in the address and then click a button to set the Subscriber Module coordinates, you have to copy-and-paste the coordinates out and manually put them into a dialog.

Thanks for the help everyone.

One last note on this.
In order to have the Inventory Summary actually execute after the upgrade to SP4, I had to copy a file to a different name.
I saw in the apache error log that the web server couldn’t find a file when I attempted to run the report.

Here are my commands :

cd /usr/local/cambium/wm/server/html
sudo cp JFreeChartsResources.properties JFreeChartsResources_en_US.properties

I did not have that issue.
Seems that your LOCALEs are not set.

do a
>locale -a {to check to see which locales are enabled}
>sudo nano(vim) /etc/locale.gen (enable the locale needed by uncommenting it)
>locale-gen (re-load new enabled locales)
>locale (check to see current locales in use)

This may resolve many more app related issues you may be faced with.
here is an example:
uncomment these in locale-gen
en_US.UTF-8 UTF-8

Read more at https://wiki.archlinux.org/index.php/locale

The locale is set properly.
Since I am using CentOS the commands are a bit different.
CentOS does not have a locale.gen file

The output of " echo $LANG " is LANG=en_US.UTF-8
The output of " locale " has en_US.UTF-8 for all variables except "LC_ALL"
a " cat /etc/sysconfig/i18n " shows LANG=“en_US.UTF-8”

Wireless manager loads online maps but after a minute comes back with

Failed to connect to Google Maps. The physical map will be unavailable.

Please check that you have a working Internet connection and that your Java proxy settings are correct.

Cambium Wireless Manager V4.4.12


Google has made some changes into their calling APIs, thus we were facing this ssue in WM v4.4.12 release.

We have already been fixed this issue in WM v4.5.6. You need to upgrade your current WM to its latest version.

You can download latest copy of Wireless Manager from here:


Please let us know if you still facing this issue on the latest release.