2.4 to 2.4.1 and 2.3.4 to 2.4.1 upgrade error

I am trying to upgrade a 2.3.4 SM and a 2.4 GPS AP to 2.4.1 and I am getting this error.  I have tried to upgrade via the CNS and from the GUI of the SM and AP.  Same problem.  Any Ideas as to why?

Jan  5 14:45:33 DMV-ePMP02_EAST snmpd[19786]: SW_UPD ERROR: Firmware: Digital signature check: failed


Can you try downloading the software bundle again? I'm suspecting a corrupted file. 


Hi Matt,

Have you tried with different webbrowsers?

I suggest you to decrease security level in Internet explorer and try. If the still persist then try the below one.

Check this option in Internet explorer property i.e Start>>>Run>>>type inetcpl.cpl>>OK>>> Security >>>Select Local Intranet>>> Custom level>>> Scroll down and check for this option "Don't prompt for client certification selection when only one certificate exist>> Enable/Disable.

If the above option is Disabled then please enable and try. If it already enabled then please disable and try.

Please let me know your feedback.


Vijay Gnanamurthy