BAM 2.1 resolution

My earlier post asking for help on the BAM login didn’t generate any responses, however we forged ahead and tried RH E3 and that was an even worse experience, talk about chicken and egg syndrome!

Finally on our 3rd OS attempt we did CentOS, very slick and everything worked exactly as it should. No fighting with RPM’s, going back and forth trying to get “updated” out of date packages.

If you are thinking of setting up BAM and/or Prizm, just use CentOS, it works.

I agree. I installed 2 BAM servers on low end refurb Dell machines. I also have them as lic. managers with the 3rd lic. mgr. being a Windows 2003 machine. Everything works great. Took about 4 hours start to finish to set all three machines, that includes installing CentOS. (windows was allready installed and running)


I am installing all in one, One server for all. Following the notes, i need to install MyODBC :-

1. Visit HTU … 51.htmlUTH.
2. Select and download Version 3.51.07 or later MyODBC-versionnumber.rpm.
3. As root, enter rpm -Uvh MyODBC-versionnumber.rpm.

When i go there i get, mysql-connector-odbc-3.51.12-1.i586.rpm, doing the rpm install below is the error :-

error: Failed dependencies: is needed by mysql-connector-odbc-3.51.12-1

can anybody help ?

looks like an error on canopy docs, i installed the MyODBC and it works great.

NOPE, the server giving error that cannot connect to ODBC driver.

Any help ?

It looks like the ODBC driver changed since the doc was created. I tried it and ran into the same problem. Call our support center for a work around.

Would be great if you can post your workaround here. So people can benefit !


Due to licensing we cannot distribute the ODBC driver, that needs to come from MySQL. If you purchased MySQL you should be able to get an older version that doesnt have this dependency issue.

We are trying to work with MySQL to get them to post the version you need on their website.

On my RHEL3 machine I am using this:


and didn’t have any such issues.

The issue is with the latest driver, mysql-connector-odbc-3.51.12-1.i586.rpm. It forces you to find other dependencies and I had a tough time finding them. There are sites that post the older version but we cannot distribute it. ... 1.i386.rpm

Thanks for the link, will help people who have come to a halt after looking at the pile of dependencies !

The only problem is that we recommend in the release notes and user guide that you use 3.51.07 or later. That link is for 3.51.01.

Canopy_Support wrote:
The only problem is that we recommend in the release notes and user guide that you use 3.51.07 or later. That link is for 3.51.01.

This site had a fairly complete archive of the myODBC packages. ... 1.i586.rpm