Bootp Protocal Filter Bug

I’ve discovered a bug with the Bootp Protocol filters.

When the SM has NAT enabled and the Bootp filters enabled it will not give out DHCP leases to any connected devices, which is what it is meant to do.

The bug is that when the filters are deactivated the SM continues to operate as if they were still active. The only way to re-enable DHCP is to return the SM to default and re-configure it.

We have seen this on about a dozen SM. We are using 8.2. I’ve not tried this bug with any other version.

If you have seen this or find a solution without having to re-configure please post it.

Yeah, read about that in the Release Notes manual.

4767 note
Bootp Client Don’t configure an SM to request its IP address via
filter blocks DHCP by enabling the DHCP State (on the module’s
SM’s DHCP of Configuration => IP page), and then block that request by
its IP address enabling the Bootp Client Packet Filtering (on the
Configuration => Protocol Filtering page).
Since filters are applied to all packets leaving the RF side
of the SM, including packets generated by the SM, and
since DHCP uses bootp, this configuration blocks itself.
If it is desired to enable DHCP on the SM and avoid ill
effects from errant DHCP requests from subscribers,
enable the Bootp Server Packet Filtering on all SMs in
the sector (so responses are filtered/discarded), instead
of the Bootp Client filter.