C# Soap/XML problem: Northbound Interface Not Available.

I need some help figuring out what I am doing incorrectly.

I cannot confirm that the Northbound interface is set to handle my requests however , but I do get a info back on this method:
getPrizmElementSearchFields ();

Here is the error I am receiving on method call getPrizmElements();

System.Web.Services.Protocols.SoapException: java.rmi.RemoteException:
Northbound Interface Not Available.; nested exception is:

java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:

java.rmi.RemoteException: Invalid Service Name:

ientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)

at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String
methodName, Object[] parameters)

ts(String[] fieldNames, String[] fieldValues, String[] operators)

at OasisProvisioning.OasisMotoCanopyWireless.GetElement(String
sElementName, String& sOutput, String& sError)

Sample Code:

public bool GetElement(string sElementName, ref string sOutput, ref string sError)




//Element Name

string[] SearchField = new string[1]{“Element Name”};

string[] FieldValue = new string[1]{sElementName};

string[] Operators = new string[1]{"="};

myPrizmElement =
myNetworkIfService.getPrizmElements(SearchField, FieldValue, Operators);

sOutput = XmlHelper.SerializeObject(myPrizmElement, ref sError);

return true;


catch (Exception ex)


sError = ex.ToString();

return false;



You should first check if the Northbound Interface is enabled on Prizm Server using Prizm ServerAdminTool. If it has not been enabled (it looks like it is not) then enable it (XML interface). After that restart the Prizm Server.

I had the our client do that already.
I saw that suggestion in one of the others posts.
this did not seem to help…

Is this not what this screen shot is of?

Do one more check
1. check configure file Canopy/Prizm/config/prizmconfig.xml looking for <service name=“Canopy.Prizm.NorthboundInterface” enabled=“false” …
If enabled=“false” then change it to “true”.
2. check configure file Canopy/Prizm/config/northboundinterface.xml looking for
<Interface name=“SOAPInterface” enabled=“true”/>

Still get the same error.
Northbound Interface Not Available.