C3VoIP-200 and 200P Firmware Upgrade?

Where can we find the firmware to upgrade the C3VoIP-200 and C3VoIP-200P devices to 4.1-R2 (so they can be connected to cnMaestro)?

Thank you, 


Have you looked around under the 'Administration' tab on those devices to see if you can add a Cambium ID and onboarding password? I was able to add my 200P test unit with a very early firmware release (i want to say it was like 3.0) to cnMaestro. Alternativly, because it's a 200, you could just claim the device in cnMaestro just by entering in the serial number. Once it's been onboarded you can apply the newest 4.1-R2 firmware to it.

The C3VoIP-200P on V3.10 does not have the "Cambium Network Manager" tab available under "Administration", nor do I see a location for a Cambium ID.

I tried claiming the device as suggested. It was accepted but not found and is queued for on-boarding (Interestingly, the 3x R200 devices I've tried claiming in cnMaestro have not accepted and I had to claim them manually).

I still suspect I need a file to upgrade manually first, then cnMaestro can take over.


Cambium Network Manager functionality is available from 4.0 Release version.Please upgrade your C3VoIP-200 device from 3.10 to 4.0 / 4.1 version.


C.P Sharma

Technical Lead , QA

Cambium Networks


For Upgrade process please  open the Web UI and go to Administration->Firmware Upgrade , Press Browse button and select the correct firmware file and then press Upgrade button and wait for device to upgrade and reboot.
Please upgrade twice if you have 3.10 firmware and you are upgrading to 4.0 or 4.1.After upgrade go to Administration->Reset to Factory and reboot device after reset to factory defaults.After reboot your device is ready and your can manage it using Cambium Network Manager / cnMaestro.


C.P Sharma

Where can I get the latest firmware for the 200/200P model? I don't see it at support.cambiumnetworks.com

I found an issue with the 3.10 software on my 200P model at my house. My WAN is DHCP and acquires a lease from my SM just fine. DNS proxy is disabled on the SM so that the router gets the actual DNS servers. The 200P's LAN DHCP server is set to manual DNS mode handing out the router's LAN IP as the sole DNS server (the second box is empty). DNS proxy is enabled. However, the devices on my LAN are getting the 200P's LAN IP as the primary DNS *and* the first DNS obtained on the WAN as the secondary DNS. That is definitely not how the 200P is configured.

Looks like a DHCP server bug in the 3.10 software and I'm wondering if this is fixed in 4.x?

I'm doing extensive testing at my house with NAT and DMZ on my 450SM. We would like to begin moving customer SMs to NAT and get off of bridge mode because it's a management nightmare. And I also would like to convince the boss that the Cambium C3VoIP/cnPilot routers are woth the extra cost. My 200P has been working great except for this one small issue.

George et. al -  By the end of this week, we will have the software for converting any legacy C3VoIP-200 to the new R200 functionality available on the download section of the support site.

we are looking into the reported issue as well and will contact you if we need more details. thanks for letting us know.

Hi George,

Thanks for sharing your feedback.We will look into this issue and get back to you soon.

New firmware is expected to be  available on support site by COB Friday.


Chandra Sharma


I recreated this issue in my device and observed that the first DNS obtained on WAN side is taken as secondary DNS of LAN side.
What are the scenarios in which do you think this behaviour is having disadvantage or can cause any issue while DNS resolution.

v4.1 is now posted at https://support.cambiumnetworks.com/files/r200/. After upgrade, the product name will change to "cnPilot R200" to reflect the new Cambium branding for C3VoIP. This vesion will also allow you to manage the  device via cnMaestro cloud management. 

@chandrasharma wrote:


I recreated this issue in my device and observed that the first DNS obtained on WAN side is taken as secondary DNS of LAN side.
What are the scenarios in which do you think this behaviour is having disadvantage or can cause any issue while DNS resolution.

Besides the operation not complying with the configuration on the 200P...

1) I don't know if it's some piece of software or user intervention, but we run across customer PCs and other devices that have our DNS servers statically configured. If we move/change around DNS server IPs on the network, it's only a matter of time before we get a bunch of calls because the DNS they're using are no longer available.

2) We have also had malware on customer PCs that are querying our DNS servers directly flood request, I guess in an attempt to poison our DNS caches.

So I always, always, always want customer LAN devices querying only the DNS proxy on their router.


Thanks for sharing your experience.We are working on fixing this issue in our next firmware release for cnPilot-R200/R201.

1 Like

I've been experimenting more with my home R200P. I installed a 2GB flash drive in the USB port. Then I enabled the SMB server. It doesn't seem to allow guest access to the file share at all. After playing with it for a bit, I found that I can browse the share from Windows PCs by logging in with the "Normal User" account. My guess is it's just a Samba config tweak under the hood that's needed.

Here's a screenshot of my SMB config: