Cambium Discovery Tool - Doesn't Work

We have installed  CambiumDiscoveryToolSetup-1.0-RC5-signed.exe in three different Windows 7, 64 Bit PC's (along with 64 Bit Java Version 8.xx).

Unfortunately, we cannot get the Cambium Discovery Tool to work.  When you click on it, a black dos screen flashes up for a 1/2 second the goes off. 

The computers just sit there. 

Is there a known problem getting the program to operate in a 64 bit machine with Intel I5 processors?

Hi!

It was reported that you might need to manually install winpcap(https://www.winpcap.org).

Can you please also try running it as an administrator? 

Thanks,

Dmtiry

1 Like

I installed WinCap in one machine.  That appears to have fixed the problem. 

This is the first time that I have seen the Discovery Tool work.

Several suggestions:

Might we be a able to get a button on the Menu Bar at the top to click on for the Discovery Tool to update?

A "Print Button" to print out the page would be nice, as well as some way in the program to save the list in a database file that one could call up at a later date if needed.  

When one saved the list in a database file, it would be the Discovery Tool to save the file with the Discovery Program automatically naming the file with the date and time that it was saved, like cnMaestro On-Premises automatically does.

We use Wireshark a lot and found that the version of winpcap in the older Wireshark packages did not work with CDT. The program opens, just never finds anything. We discovered that Wireshark was locking the service for its sole use. The latest version allows multiple programs to simultaneously use the winpcap service.

1 Like

Hi Douglas!

Thanks for pointing this out! It was one of the issues that were pretty hard to troubleshoot. 

What exact version of wireshark/winpcap that doesn't work with CDT? 

Dmitry

To be honest, i do not remember the exact version, but the august build of wireshark does work, just put CDT on my desk pc and it has the august build. Last time I remember downloading wireshark before that was early last year when I reloaded my laptop. When CDT came out, it worked but only if you selected to reinstall winpcap. If you ran wireshark before CDT then you couldnt find any devices with CDT. A reboot later and it would work. I do not think of this as a flaw in either wireshark or CDT. Wireshark comes bundled with the required winpcap that is know to work, but is not the latest version. Same with CDT. The latest versions allow packet capture to multiple programs so it in my opinion was a library issue that was resolved.
My laptop also has the august build installed, so I may have done a blanket update which is a common practice for us.

I would simply set the required version of winpcap to be newer than august 2017 and post that in the download notes on the CDT download. It looks like the change was between wireshark versions 2.0 and 2.4 but I can not nail it down to the exact version of winpcap.

I am having same problems. 

Hi,

Make sure you have latest winpcap installed(either one bundled with CDT or wireshark 2.4).

Thanks,
Dmitry

Hi,

I have several computers that the Cambium Discovery Tool does not work for me. What it does to me is the following: once I open it and give it administrator permission, the Java window opens but it closes automatically.

I have checked my version of Java and it is up to date, Wincap is also up to date and I don’t know where it can come from.
Can you help me?

Same for me… Updated a DOS window flashes, then a Java window labeled Cambium Discovery and it just closes. :frowning:

dmburgess

Did you ever happen to find a resolution for this? As I am running into the same issue.

Nope. its java, i just calked it up to that, as java sux. Never worked … . .

This fixes the problem.