Can only get 20Mbps Download on TCP but MUCH higher on UDP

Both sides are running 2.4.3. Two APs are running on the same mast pointed at the same client. (One 5.1 and one 5.4) The results to this client are always the same with either AP. One AP was even setup in P2P mode with flexible timing with 40MHz channels while the other was on sync w/20MHz channels.

Ethernet on both sides shows 100 FDX and wireless link tests look fine. Signal is -60/-60. SNR is 30 or above. I've tried locking the ethernet port on the Mikrotik and the ePMP to 100 FDX and that doesn't help.

Any idea what may be causing this or how to resolve it?

Are you using a Mikrotik to Mikrotik throughput test, and if so, what model Tik's are you using? Unless you're using something high end, like a CCR, or 1100AH, then your results sound normal.

Rb2011 connected to CCR. Exact same routers get easily 300Nbps on AirFiber. Swapped to ePMP and these are the results. Tested with laptop and Mikrotiks show the same issues.

What do you get when you run the built in radio to radio speed test? Also, have you tried the ePTP mode on your 5.1ghz connection (ePTP is not supported on DFS yet)?

When you run the TCP tests, look at the CPU usage on your RB2011 and how high is it getting?