Canopy and Cisco Duplex Mismatches

All -

We have a customer who runs a Cisco 100Mbit interface with our SM, and the SM keeps autonegotiating to 100Mb half-duplex. When we force the SM to 100Mbit full-duplex, the Ethernet link doesn’t come up. The customer has forced their side to 100Mbit full-duplex, and our SM still thinks it is half-duplex.

Why, when both sides of the Ethernet link are forced to 100Mb FD, won’t the Ethernet link come up?


Too long of cable run, interference, hardware issues… I see it all the time. That is why we select all 4 of the options. There are times when the link will go from “100 base-t” to “no-link”. That is when we have to select only 10-base t 10/100.

I have the same problem as chale99. and Its not the cable length. If I only tick the SM to 100full and also force a Cisco router to 100full it never sees the link. Like Chale99 I need to have half duplex also selected for it to work.

We had a similar problem with an AP connecting to a Cisco 2950. We would drop link to the switch regardless of speed/duplex settings. Even when forced down to 10/half, the link would come up for a while, then go down. No apparent reason. Two other BH units on the same switch did not exhibit these problems. We pulled a completely new cable (~250ft), and same problems still existed.

Finally, we replaced the power injector.

Problem solved. Go figure.

I am having the exact same problem. We have a SM connectec to a PIX 501. It was working for 3 months then from on day to the next it won’t link up. No traffic can pass through. I tried every combination of Speed and Duplex on the SM and on the PIX. The only way i can get it to work is by placing a Linksys unmanaged switch between the SM and the PIX. I replace all cables, Arrestor, Power Supply and even the SM. And still no luck.

Does anyone else have any suggestions to get the SM to work directly to the PIX with out a switch between them?



this is crazy,

I saw similar broplem on the seekend with a BH going into a cisco 3550, on BH everything is selected but my CISCO was set to FULL - 100, started getting CRC errors, switched the interface to Auto and it works fine, previous to this it had been working fine.

6 months ago spoke to Motorola who adviced me to manually set everything to 100-Full because CISCO is terrible at negotiating speeds, (actually I have experienced other problems with CISCO negotiation, usually it is when you leave it to auto neg, but looks like with canopy its the other way round.

Funny thing is that when I set to Auto Neg it negotiated at 100 Full.

Try diff setting on the CISCO/router side and check all settings on the Canopy side

I have seen another problem with Cisco over WLAN:
One Cisco router only capable for max 10MbFD
On the other side one Cisco switch.
One native, one is with tag
What’s happening is the router sees the switch trough the tagged VLAN and believe it has a direct line to it and starts nagging about different speed and duplex.
After a wile the router reboots …
Solutions turn off the check on both sides

was woken up at 5 am due to no connectivity.

we have a 20MB BH connected directly in to a 3550. 3550 was set to 100 FULL whereas BH was allowed to neg, port light orange, did some checks, cisco port was 100 FULL BH was 100 HALF, changed settings on BH, now neg on both side fine, but light still orange.

Traffic will not pass through the switch, the only thing I am seeing is a high numebr of multicast packets on the interface.

Tried both auto and manually setting both to 100 and 10 but same problem.

Take out the cables and stick them in a $10 switch and its working fine.

Any ideas ?