Canopy Mux echo problem

Hi all,

i’ve got a problem with E1 flux with Canopy mux and BH:

the connections are:

PBX----MUX_CAnopy-- BHmaster--------BHslave–MUx_Canopy–PBX

PBX are PRI E1 with internal clock,; only one E1 to be linked.
Mux Canopy (ver 3.00.00) are configured for E1 wtih LoopBack for mux near BHmaster and recovered near BHslave.
BHs (ver 7.2.9) are 10Mbps in HW scheduling and Full 100 Negotiation (not auto)
Link is good (RSSI 60dbm, Jitter 1, distance less than 1Km)

The problem is that only on the slave side customer listen a echo return of his voice.

We have tried to change clock on mux (same side LoopBack) but nothing is changed

Length of E1 cables from mux to PBX are less than 1 meter.

How is possible solve echo problem?
Customers say that using Telco service there aren’t problem like this.
I haven’t idea… E1 mux configuration are poor


You might have some difficulty in getting help on this issue from the forum as this is a user forum and not monitored or supported by Motorola tech support.

Any urgent support needs should be addressed via email or our toll-free number 1-888-605-2552. Internationally you can call 1-217-824-9742.

do you try to change length line? does your PBX support echo cancellation?

i don’t know this slide will help or not : … 5.rar.html


Hi guys
thank for your suggestions.

The strange fact is that if i try to change length using Command Line, mux can’t understand command.

I will work on PBX configuration first


I have no experience with the Motorola/Canopy MUX, but I do have experience with RAD Multiplexers. Both RAD models I have worked with have an option in their configuration for Echo Cancellation. In my case I was working with E&M interfaces. Take a look at your E1 interface options.

The perception of bad echo is caused by the high latency of packetizing the TDM traffic, sending it over a wireless network, and the mux’s jitter buffer. The motorola mux probably has some kind of buffer, anyways.

To fix it, you need better echo cancellers. Basically, your echo cancellers will cancel echo heard by the other side, and vice versa.

Another person on the forum suggested using a Rad mux with its own echo can, which is probably the best solution. Rad has a lot of experience packetizing TDM traffic…

We had the exact same problem, and ended up replacing the Moto Muxes with some from RAD, the VMUX 110. They offer compression and echo cancellation, they cost more but are less in the long run considering you don’t have the problems and the time trouble shooting them


As GPE mentioned there isn’t any echo cancellation in the Canopy MUX and if the PBX doesn’t handle echo cancellation then you need a MUX that does. There is a setting in the GUI that will allow you to change the length; you need to connect via hyperterminal with a serial cable.

Hi guys

I confirm that PBX do not support echo cancellation.

Than I tried to change length by Command line on to Canopy mux, like your suggestion, but mux replyto me with an error.
Mux can’t understand the command.

Than on the GUI is not possible configure length on configuration window of E1.

Exist some software upgrade of canopy mux?

I’ve just sold mux and canopy antenna to the customer and is not a fantastic idea report to him that now we have to change mux with ather brand.


I feel your pain, but it is best to bare it and change the muxes, Moto OEMs the muxes from someone else, so they are not in a position to add features, they can only recommend that you go to another brand. I know that is not what you wanted to hear, but trust me RAD muxes are far more capable than the Moto muxes.

And they will solve your problem