Can't synchronize my controllers.

Hi there.
I've been dealing with a very reoccuring issue today. When adopting e410s, they are immediately considered out of sync, and I can't synchronize them again. When I click on the sync now button, it launches successfully but then times out. This is happening on all the APs I try, regardless of which contrôleur I plug them on (I'm plugging them on controllers because my clients have controllers, so it sets the IP passerelle to what it will have to be on-site). 
Now I've tried switching them around, using new ones, forgetting them from cnMaestro and adopting them anew, even resetting the AP through local access to the AP's UI, then readopting them, but nothing will do.

And this is only when I have the luxury of seeing them connected on cnMaestro. Most of the time they just don't show up there. When they do, I sometimes try to change their configuration, but it also times out, and even disconnects the AP (light goes from blue back to green, sometimes even red).

What scares me is that I tried plugging back in some of the ones I'd finished setting up and packed to ship out to my clients, and those are running into the same problem: the light goes green, never switches to blue, and I don't see them on cnMaestro. This means that the ones I've shipped out yesterday, and the day before that might have the exact same issue and need to be returned to me next week when the tech on-site tells me that the equipment isn't working. I can't even just decide to say that it's okay as long as they're emitting a signal and giving internet access because the ones I have here are not. 

Does anybody know what's going on? 


It sounds like the configuration being applied to the devices is causing the device to lose connectivity to cnMaestro.  The configuration push then fails by timeout 5 minutes later and the device is marked Out of Sync.  Is this correct?  When this happens, the device will roll back to its previous configuration after 15 minutes in order to regain connectivity to cnMaestro.

If this is the case, I recommend reviewing the AP Group to ensure the network settings are valid.  Then look at the device-level configuration page's "Device Overrides" section.  Configuration set there will be applied to the device instead of the AP Group settings for that single device.  In particular, verify the Primary VLAN settings.  If "Auto-sync from device" is enabled, cnMaestro will read those network settings from the device and then push them back as part of the AP Group in order to prevent them from being changed.

Thanks for the input, I'll have to try this on Monday. I'll let you know if it works.

Okay, so, I took a look and can't find the setting you speak of in the device's settings.

Also, in regards to what you describe the problem as being, it isn't quite that. The APs do lose their connec tivity to cnMaestro, but they don't roll back to their previous configuration and connect to it again. Instead they just stay green, and every now and then, one will turn blue (supposedly meaning that it is connected to cnMaestro) but when I try to configure it through cnMaestro it times out and goes fails the job, then the AP turns back to green. 

To give you perspective, I have left a few of them plugged in all weekend hoping that it would give them time to fix themselves, but when I arrived this morning they all had the green light, and none were accessible through cnMaestro. If they had been reconfiguring themselves so they could reconnect, shouldn't they all be blue by now? 

The problem has evolved, and now they just never turn blue, even when I pull a new one out of a box and adopt it. I've tried 2 switches and 2 controllers with no success. I have 40 of them just sitting here and no way to use them, and 60 either on their way to my clients, or already there, and no way to know if those will actually work. This is just great.

So the connectivity issues have been solved, it was simply one of my colleagues who'd changed the settings of other hardware thus preventing the APs from properly accessing the internet. Even when I asked if they had any idea what was wrong on Friday, they said they didn't... Then this morning they told me as if it was blatently obvious that that was what had happened. 

1 Like

Good to hear that you got it solved.  Another option for troubleshooting connectivity issues like this is to use the Ping tool on the device web UI.  This is typically found under the Tools section, depending on the device type.  This can be used to determine if the device is able to actually contact cnMaestro.

For reference, below is a screenshot of the Device Overrides I was referring to earlier that includes the "Auto-set from device" option.