Can't update

Hey all, I apologize ahead of time  for my lack of knowledge with these devices, but I've been having nothing but trouble since I've attempted to install these.

I get pretty constant disconnects (every few minutes). However, before I enlisted help, I wanted to update the firmware (to 14.2.1). These aren't in production yet so I can reboot at will currently.

When I attempted to install the latest build that was available using the  CNUC tool, I get the following error message:

Host: x.x.x.x;ESN: 0A003EB626D8;Message: Failed to upload file ptp450_c120.img, Software caused connection abort: socket write error

I did some research here regarding the same error and many recommended rebooting the devices, which I've done. I also allowed firewall exceptions (and turned it off) and verified that I  can access  the local web server from another machine, so I don't believe it's a firewall issue.

The devices currently have no special security setup and the tool 'discovers' them, but just cannot update.

I appreciate any assistance anyone might be able to give. I also tried to update each end, it does this for both devices.