Can't upgrade firmware or view WPA password

Hello. We have a customer who forgot their WiFi password and we are unable to view it under "View Device Configuration" as the password is scrambled. I was told this would be fixed in a future firmware version. We're on 4.2.3-R4 and it's still scrambled. The next step for us is to upgrade firmware to 4.3.1-R1 then use profiles to change the password.

The problem we have is that the router has failed the upgrade 4 times with the error "Software upgrade failed due to unknown error". Each time it fails, the router reboots and uptime starts counting up from 1min so but after letting it settle for 5 minutes and then trying the upgrade again, the same error occurs.

So now I have no way to SEE the current password or CHANGE the password to something else as the firmware won't upgrade. I have not been happy with cnPilot and Maestro in the ability to view and change simple things like SSID and for this reason, we're evaluating other options that are easier to use.

Please help us figure this out for our customer. What do we do next short of sending a truck out there to fix it?

Thank you

Clear password is  fixed in 4.3.1, Is it possible for you to try upgrade from device UI ?, is  this working?.

Is it possible to give a  remote access so that we can take a look and debug the issue ?

We had customer factory reset router for us and then the remote firmware upgrade worked at that point. First time we've seen this happen where we couldn't upgrade firmware.