CBRS active. Now I want to change channel/channel width

Frequency space is pretty clear, I have no competing WISP's  in the area, and I want to change to 40MHz wide.  What's the best practice to do this?

Go to CBRS in cnMaestro, change the AP settings, re-apply my CPI cert, select the AP and click "Start"   ????

I guess it is already synced from the cnMaestro tool. Yes, you can go ahead and edit the bandwidth on the cnMaestro, re-apply CPI, start and wait for the grant to be authorized. This could be better since it could go through the overnight CPAS, putting the grant into suspend state for several hours. At this point the sector could be switched into CBRS disabled (Part 90) mode, to reduce downtime.

Atlternately you could change the bandwidth directly on the AP. In this case, the AP would stop transmitting until the grant is authorized for the 40 MHz channel. In case there is no CPAS involved, or its ok to bring the sector down, this could be more convenient. 

I have forwarded this to the support team.

So, we moved forward with this at around 1am this morning.  We wanted to adjust 3 AP's

The first one (450 first gen) went without too much trouble.  AP was at 3590MHz and we wanted to move to 3610 to give more room for another AP to go 40Mhz.  We went to the CBRS section, edited the AP information (some of this had changed on its own.  AGL had been changed to AMSL and downtilt had been changed from -4 to -2) set it up properly, applied cert info, selected all devices, clicked "Start" (error "Devices already sync'd" didnt do anything), and clicked "Sync".   AP rebooted, changed frequency, authorized all devices, and (aside from having to reboot the AP to get access to it again) everything worked perfectly.

On to AP two 450M. (this is where the fun started).  Same steps, same issues with certain details in cnMaestro having different numbers from original import.  Corrected details, set channel width from 20 to 40,  Set frequency from 3560 to 3570MHz, added CPI info, hit Sync.   Radio came back "Invalid frequency transmit disabled".  Turns out, the alternate frequency 1 was set to 3565MHz which isnt allowed 40 wide.  So, we manually adjusted the alternative frequencies to be 3575 and 3580 and rebooted.  AP comes back and has primary frequency set to 3690MHz, alternative 1 at 3565Mhz, and alternate 2 3570MHz which is now active frequency.  (still giving error Invalid frequency).  After a couple more reboots, we go back to cnMaestro and set everything back the way it was originally.  Then we adjust the Alternative frequencies to 3575 and 3580, save, reboot, change cnMaestro back to 40MHz and 3570MHz, and sync.  It reboots and all devices come back authorized.

On to the 3rd AP (450 first Gen).  Same steps, same issues cnMaestro data changed.  Set channel width from 20 to 30MHz, Set frequency from 3690 to 3680, corrected all details, hit sync.  After this, the AP sat there as "registered" and no change for 15minutes.  AP showed a clean spec ann and no reason not to move forward.  Rebooted AP and it did the same thing.  Check the CBRS logs and the log showed some error about missing antenna array information (sorry, I forgot to copy the error).  Double checked AP settings, showed the proper antenna;  checked cnMaestro and all details look good.  Attempted another sync (no change).  Attempted frequency change in cnMaestro to 3685MHz (still 30MHz wide).  AP comes back log shows requesting Spectrum Analysis.  AP sits there not doing anything for 15minutes.  Performed Spec Ann manually, and AP sat there doing nothing for another 15minutes.   At this point, we are reaching 4am.  Time to call it a quits.   Set AP back to original settings in cnMaestro (3690MHz and 20MHz wide).  AP comes back set to 3689MHz "Invalid frequency".  Manually set frequency to 3690MHz and saved.  AP receives authorization in about 5 minutes, all customers come back online.  And we are back to square one with this last AP.

Sorry, this is so long winded.  I am hoping this might help everyone.

First, double check your alternate frequencies and make sure they are in proper range prior to cnMaestro sync.

Second, If its a 450 first gen, expect to have to reboot after all your clients get authorized (you can watch through cnMaestro after you loose direct access)
Third, double check all cnMaestro settings before applying cert and saving.  Downtilt and Height type seem to commonly change on their own.
Lastly, don't exect the "registered" information in cnMaestro to change properly.  Through all of this, all my devices continue to say "Halt" even though they are authorized and online.

I am sure all the querks will eventually get worked out.  This is all just getting started.  Plan ample time during slow times on your network.  And don't be a dummy like me and do this early before work

1 Like

Specifically on your "Invalid Frequency"  observation, I took a look at this in lab yesterday.  While the "Invalid Radio Frequency Carrier" error by itself is  accurate when a configured ALT spans coverage beyond the 150MHz boundary,  it looks like if the AP is not yet transmitting for some other reason. an "Invalid Radio Frequency Carrer - transmit disabled"  error is displayed (when an invalid radio frequency carrier is also configured).  This gives off the false impression that the missconfigured center frequency/bandwidth combination is a reason or the reason why the AP isn't transmitting, when it could have a suspended grant waiting for CPAS,  or in a temporary state right after an AP reboot,  or other reasons.   I've opened a ticket with development and have been discussing with them

On your other observations on missing antenna array information or the AP stuck in some sort of static state for 15+ minutes, would be interesting to look at any logs you have, should you see these again, and discuss this further with you.   I'll reach out to you via private channel for further discussion. 

Al