CMM5 Injector will not update

I can connect to the CMM5 with tera term and run the macro.  However each time I get the following error


-ash: syntax error: unexpected "&"

I have tried several times with different injectors but the same error occurs. 

Also,  Looking at the instructions for this I see the following - Bring up a TeraTerm terminal window and establish communication with the CMM5 serial port.   Where is the serial port on a CMM5?

G'day Chris,

The serial port is the USB port. I have attached the CMM5 Quick Start Guide - See page 2.

The injector upgrade process is reasonably straight forward and the exact process begins on page 52 of the PMP Synchronization Solutions User Guide - The user guide and firmware is available from the Cambium Support Site.

Kind rergards,


I have it connected from the USB port on my PC to the USB port on the injector.   When I do a serial connection via Tera Term and try and run the Macro I am still failing to upgrade.  I get requesting bootloader then failed. there is no output on the Tera Term main window.  Any other suggestions?

another question -   is the CMM5 power injector not remotely upgradable? 

Good Morning Chris,

I just upgraded a CMM5 injector following the User Guide without issue. This CMM5 will be shipped out to my client this morning. I have found the documented upgrade process flawless through 8 injector upgrades of late.

Assuming the downloaded files are not corrupt,  and the firmware (hex file) and the Bootloader (ttl file) are in the same directory,  then I suggest the Cambium Support Team may be able to assist via a remote session or alike.

1 Like


   I agree as these steps have worked in the past.  Maybe I will try downloading the files again.