cnArcher 1.2.2 iOS 14.3 "Waiting for SM"

My iPhone with cnArcher 1.2.2 cannot seem to connect to a 3 GHz PMP 450b radio running CANOPY 16.2 SM on my home LAN. I tried manually configuring on the iPhone. cnArcher says “Waiting for SM”.

I use my laptop on the same LAN to connect to the radio and set it up for DHCP. It gets a lease. The radio can ping and do DNS lookups. The radio won’t connect to cnMaestro because it doesn’t have a radio connection. What technical requirement causes it to refuse to use the LAN to connect to cnMaestro?
“Connection Status : Waiting for AP session establishment”

cnArcher is still “Waiting for SM” even after I told cnArcher what IP to use on my LAN.

Safari on the iPhone can connect to and the DHCP assigned address.

cnArcher does have permissions for local network.

iOS is horrible for network work. I have and iPhone SE with iOS 14.3.

I’m just trying to get the software on the 450b upgraded before I take it out to install tomorrow.


Could you please do ‘Report a Bug’ which you can find in tri-bar menu. Also please share the screenshot of wifi configuration from iPhone settings.


Wifi configuration in iPhone

  1. Go to iPhone WIFI settings
  2. Select your dongle interface
  3. Change Configure IP from automatic to manual
  4. Set IP address to 169.254.1.x network (other than as SM is access through this IP)
  5. Set Subnet mask to
  6. Set Router value to

cnArcher started working. Maybe because I rebooted the phone because something else seemed to be acting funky. It worked four nights ago when I sat down to test and send a bug report. It simply worked for all four of the units I brought in to test. It even found the test AP I had setup in the detached garage connected via wireless MikroTik to MikroTik temporary link.

I use a MikroTik router and WiFi at the house where I’ve been testing. I use a MikroTik in the truck to initially setup and test the radio. It’s basically the same setup. I don’t have a battery powered router to dangle on the radio at install time yet.

I upgraded the phone to iOS 14.4 this morning for the security patches.

Today I went out to do my first install with cnArcher since the testing when it worked. Unfortunately, I had the same symptoms as previously. I could access the radio in Safari via its default address or the DHCP assigned address. cnArcher couldn’t find the radio on either address.

I filed a bug report and rebooted the phone. It still didn’t work. So, I’m not sure why it worked when it did work or why it doesn’t work when it doesn’t. I didn’t get an email response from the bug report. I’m not sure if I’m supposed to get an autoreply from that or not. I think the mail went out okay. Where I was had nearly no cell data coverage.

I used my laptop to configure the radio manually.
The below screenshot is from tonight at home. The only difference this afternoon was the different SSID for the router I keep in the truck.

The iPhone SE is a 2020 model, just in case that turns out to be important.


cnArcher could access the radio only via the default ip, not the DHCP assigned address.
Is there a particular screen name/step name that you are getting this issue. In another way, is it after onboarding or before onboarding?

When you are facing this issue again, could you please check your iPhone WIFI IP details and make sure values are as following. If possible, please take a screenshot then and share.

Configure IP - Manual
IP address - 169.254.1.x
Subnet Mask -
Router -

cnArcher could not access the radio at all.

Safari could access the radio via either IP.