cnMaestro 2.2.0 (On-Premises)

Is there a way to "unboard" device and then try uploading? Since i have downloaded a generated backup.

Hi Joseph

How many device you are managing?


If you're getting strange behavior with attempting to upgrade via the OVA option in the GUI double-check the hash value of the OVA you downloaded. Downloaded a couple copies of the OVA earlier that had an incorrect hash but just got a correct one a few minutes ago and it's working fine now.

For reference: 

SHA-256 Checksum: e46f3aa0e4ca760e905739486d8d0720868c609cba1903a085b2d3f82061164a

1 Like

Just checked the hash on the file I downloaded yesterday and it's good.  I'll try downloading again just to see if it makes a difference despite that.

I'm only managing 5 devices. 

Here's are screenshots of df -h and top's memory statistics from my system.


Top doesn't show 1GB free, but when I rebooted yesterday it did.

i have sent a private message, could you please check and confirm?

we are running right under 2000 devices. We decided to reinstall with the new ova file. It is up now.. but the upgrade never worked.

I understand that all users are in the same situation. 
Are there solutions apart from completely rebuilding the machine? Should we expect a patch?

I got connected to a Cambium employee through this thread and they remoted in to my environment to troubleshoot the issue.  In the end I was told they did find a bug that will be fixed in the next release.  He also helped me manually update.  The manual update is supposed to be documented somewhere, but I don't think I've seen that in all my research.  It involved enabling ssh, then using WinSCP to transfer the OVA to the cnmaestro host, then running a command to have it start the upgrade.  Wish I could give you the details, but perhaps they will interject into this thread with those details.

Thanks Anish!!!

Hi Tuvix_IT -- it looks like there is an issue with the image download and staging through the UI. There is a failsafe mechanism to manage this using the Command Line. Once the image is accessible to the OS (either by downloading through SCP or mounting a shared folder), you can execute the following commands:

# Extract and stage the image into the unused partition

sudo /srv/bin/cnmaestro-image stage <OVA Filename>

# View status of the extraction (wait until it completes/hits 100% -- about 10 minutes)

watch -n2 sudo /srv/bin/cnmaestro-image status

# Boot into the new image. Use the inactive partition from the status command

sudo /srv/bin/cnmaestro-image upgrade <os2 or os1>

Edit (3/30/2021): Note these steps are only a failsafe if the UI upgrade is unavailable. They should not be used for downgrades, which are unsupported.


On the homepage (Manage) and keep selected the "SYSTEM" tree, in the general map at the right of the screen, the towers become red even if a SM is offline, so the map is almost red.

I think will be helpful if the Tower become red if an AP in the tower go offline instead a single SM.



Agree. We should show tower in red color only if any of the APs installed on the tower are offline. This one looks like a bug, will validate this behavior in our lab setup and let you know. Thanks for bringing this observation to our notice.

Does the new Guest Portal Self Registration feature capture the details provided; for example an entered email address?

@Wright-Fi wrote:

Does the new Guest Portal Self Registration feature capture the details provided; for example an entered email address?

Yes it does. The administrator can configure any set of fileds (email, phone, name etc). You can also mark some optional and some mandatory so there is that flexibility too.


Thank you firefly!


I had the same problem with uploading 2.2.0 OVA via GUI (stopped at 100%, wait for a 1-2min and got error "Failed to get upload status"), but then I tried rebooting virtual machine and after that uploading file and it worked.

I was using Internet Explorer and upgrading from cnMaestro Version 2.1.1. r14.

Kind regards

Am I the only one with poor Satellite view resolution? 

This screenshot is from Barcelona harbor, tried in different countries, but always the same (low) quality?

I am using the Version 2.1.1-r14 and find here the major bug is-

I am restricted the device limit 1 in the guest portal > add plan but its not work like when another device connect with same voucher previus device is disconnected. 

Now my question is - This problem fixed with the new version  2.2.0 ?

Another question is- Can i migrate to new version without loss any data like wlan, voucher etc?

Maybe this is a feature request, but would it be possible to release the ova's with the vlan package pre-installed?  We use cnMaestro with subinterfaces (multiple vlans).

Currently any new ova upload blows out the OS files (including the vlan package that we install) and I have to modify the vm network to install the package, load the 8021q, re-trunk the vm, then apply the subinterface config.  If the package came pre-installed on the image, it would save us a lot of time and back and forth with the system team.

Also, whoever decided that this version of cnMaestro should change the initial console login screen to have bluish text clearly does not actually use the cli.  It is hard on the eyes (blue is the worst possible color to choose), is not great for disabled accessibility, and generally looks terrible.  Even my co-worker who never uses cnMaestro commented on how awful it looked (and she rarely says anything negative!).  Please tell me it was a rash, last minute decision by an intern or something!

1 Like

I went ahead and installed as a new OVA and imported the data.  So far so good ( no blue CLI :D ).  The only issue is all towers are showing as down which is a bit annoying.  Hopefully that gets patched soon in a package update.

A post was split to a new topic: “Server temporarily unavailable” with new 2.2.0 On-Premises instance