cnMaestro Cloud 2.1.1 not on boarding cnMatrix


- cnMatrix EX2010-P running 2.0.4-r1 firmware, default configuration. Get DHCP IP address.

- cnMaestro cloud 2.1.1-r17

I have added the serial number in cnMaestro without a problem but it never onboards. 

"Waiting for device" since yesterday.

I have removed it a number and re-onboarded it etc without success. 

Other devices are fine. 

Anyone else seeing this and any suggestions?

Thank you for your feedback.  This should work.  Please contact support so we can learn about your detailed configuration.

Hi Martin,

Please make sure IP address of dns server (nameserver) is present on cnMatrix, either assigned by DHCP server or configured manually. To check for dns server, use CLI command 'show ip interface' and look for Nameservers or

go to Layer 3 Management->DHCP Client on GUI.

Also, make sure default route to reach the internet is present. Default route can be assigned by dhcp server or configured manually. To check for default route, use CLI command 'show ip route', or use Web GUI.


1 Like

I would like to do a follow up to Martin's request...... I have the exact same switch configuration and version.

My issue is that when I take off the DHCP configured IP, and place on a static IP and a static route, I can't find any spot to have DNS.  The fields for the DHCP client don't work and don't make sense since I am not using DHCP at that time.

What GUI page and elements do I need to go to so that I can add DNS to my static assigned switch?  Without the DNS it won't resolve the lookup for cnMaestro.

Mike Greenfield

Following this with interest as static assignments are the only option in my envirinments.

I finally found some time to get back to this issue. 

Still not onboarded btw. It's been a week.

My cnMatrix is set up for DHCP and according to the CLI, it has proper IP, gateway and DNS

I can ping no problem from the CLI.

However .... when I try to ping from the CLI, I get a "cannot resolve host name". 

From my computer it works no problem. Very strange. 

BTW: On my MAC for SSH, I get the following error

"no matching cipher found. Their offer: 3des-cbc,des-cbc,aes128-cbc,aes256-cbc"

In order to get in, I have to use an older cipher using the following. 

ssh -c aes256-cbc -l admin

Can this be fixed. 

In case this helps, certificate error......

Problem solved! 

As this is a lab environment, I sometimes use On-Prem, other times cloud.

I had my on-prem turned off but I still had a DNS entry for

Seems that although the on-prem box was not there, the cnMatrix would always try to go to and never make it to the That is the logic flow for cnMaestro so it makes sense. 


At least they are now onboarded :)

To configure DNS server, please use the following commands:

config terminal

ip name-server ipv4 <dns-server-ip>

Hello everyone, just wanted to ask, is there a command to specify the cnmaestro URL?


For onboarding cloud cnMaestro at, there is no need to specify the URL address. cnMatrix will automatically discover the cloud.

For onboarding on-premise cnMaestro, cnMatrix supports DHCP options 43 and 15 to learn about on-premise URL. The URL can also be configured via CLI command:

cnMatrix(config)# device-agent url https://<on-premise cnmaestro ip>