cnMaestro Connection Status: Invalid Serial No


Can you please try to perform the PING test from the ePMP device user interface.  Usee Tools --> Ping page.  Try to ping both "" and "".  If Ping fails, can you check your DNS settings on the device?

Showing the same thing, was there a system change at the end of last week?

Approx 3 days 12 hours ago?  That's when I'm showing them going offline.

I have 20+ devices that are showing offline.

I just checked and they are all Force 180's with a 12 digit serial number.

PING ( 32(60) bytes of data.
40 bytes from ( icmp_seq=1 ttl=47 time=100 ms

Looks good.

Emilio after getting off the phone with you I realized my pings were not going through because I was not giving them a good enough TTL value.  

I managed to get all of my CPS to come back up by just simply going into the Units themselves and re-entering my ID and onboarding password.   Even if it is in there retype it.  

I am still currently working on still working on onboarding my ePMP1000 AP I unclaimed.  That one is a little differnt than my CPEs because it's on a nonroutable going through a router that is set up just for it to do NAT.

Ya that's weird, I wonder why that is?

It looks like it lost it's configuration or something?

I haven't done anything on my end. (firmware or network changes)

Reboot doesn't fix it, but going under config / system / remote managment and entering the credentials again works.

It goes to pending approval then goes to a connected state after a few seconds.

Good to see that it worked for you as well.  

I had issues with my AP taking.  I had to give it ID and number so it would give me an incorrect ID error.  Then go back in and re enter my correct ID and it took.

Re-entered Cambium ID and Onboarding Key and all units reappeared right away, curiously all with the same session uptime of 1 day, 2 hours and 10 minutes as of 6:55pm EST.  I did the pings to google and cambiumnetworks on 1 device before re-entering the ID and the pings worked...anyway, problem resolved, thank you and keep up the great work, we are reallly enjoying the new equipemnt, system and support from Cambium.

We identified one of the problem for existing devices which were onboarded but later point in time when device get disconnect from cnMaestro, it starts complaining "Invalid Serial No".

We have fixed this issue, all your devices should connect back without giving any error.



We too are having trouble with multiple ePMP's saying "Invalid Serial Number" in the cnMaestro Connection Status page on the ePMP's.  

Due to the problems with the false DFS firmware, we are running Version

Was the fix that you referred to in cnMaestro or in some version of ePMP firmware?

I can see this error in our logs, and I believe it is a missing entry in our database. We should be able to fix it by tonight. If you need to onboard the device now, you should be able to use the Cambium ID method as an alternative.

This issue is fixed from cnMaestro end and can you please retry it

I appear to be having this issue again.  It has been going on for over a week now.  It shows that there are 6 devices offline.  I log into the unit and they show Invalid Seriel Number.  I've tried to unclaim 1 and re-add it via SN in Maestro and have put my Maestro info in the unit.  The unit keeps attempting to connect but Maestro never sees it online.  It still shows red in the onbaording queue.

This is happening to me now as well.  I deleted a device that was stuck in 'Pending Update' (like 130 of my other devices) and when it came back into cnMatestro (cloud), the SM is reporting 'Incorrect Serial No.'  How can I fix this?


Is this still a problem?  Can you please email me a few sample serial numbers that are giving you this problem?  Email me at



Thanks for reaching out offline.  Glad to hear the issue was previously resolved.

actually this is still a problem in 2019 now. i have 20 devices offline.  why do you not fix the less than 12 digit msn?

I got two AP with the same error after upgrading to 16.2.1.

One 450 and one 450i

07/31/2020 : 05:30:00 WEDT : : Attempting (re)connection in 5 seconds
07/31/2020 : 05:30:33 WEDT : : Error response: [{"error":{"level":"error","message":"Invalid Serial No","code":1000}}]
07/31/2020 : 05:30:33 WEDT : : Not able to get cloud details, can't proceed
07/31/2020 : 05:30:33 WEDT : : Unable to discover cnMaestro URL (re-discover in 62 seconds)
07/31/2020 : 05:30:33 WEDT : : Attempting (re)connection in 62 seconds
07/31/2020 : 05:31:38 WEDT : : Error response: [{"error":{"level":"error","message":"Invalid Serial No","code":1000}}]
07/31/2020 : 05:31:38 WEDT : : Not able to get cloud details, can't proceed
07/31/2020 : 05:31:38 WEDT : : Unable to discover cnMaestro URL (re-discover in 70 seconds)


Could you please open a customer support ticket in

Hi Martin,

This issue fixed is cnMaestro 2.3.0, Kindly upgrade cnMaestro On-Premises version 2.3.0 or above to solve this.

To download latest cnMaestro click here 



2 posts were split to a new topic: ePMP 1000 MSN shown as N/A in cnMaestro