cnMaestro On-Premises version 1.3.0 is available

cnMaestro On-Premises version 1.3.0 is available for download from the support web page:

Significant changes:



Administrator Limit

Administrators limit is increased from 3 to 10.

Device Limit

Overall device limit is increased from 4K to 10K. Please refer to On-Premises Quick Start Guide for minimum hardware recommendation to manage 10K devices.

Important notes:

cnMaestro 1.3.0 is a Package release rather than a full OVA Image. It must be applied on top of an existing 1.2.2 On-Premises installation. Please follow the steps detailed in section 6.2 of the cnMaestro On-Premises 1.2.2 Quick Start Guide (“Updating cnMaestro Software”) to perform a package update on an existing OVA.


Upgrade from 1.2.2 worked without issue, appreciate the increase for Admin accounts from 3 to 10. 
Are there any plans to allow read-only accounts? Would like to give some of our Tier 2 support agents access, but do not want them to have any access above read only.

1 Like

Ohh ohh ohh Excellent!

What is the upgrade path from  1.2.1 r1  ?

@Steven Kenney wrote:

Ohh ohh ohh Excellent!

What is the upgrade path from  1.2.1 r1  ?


Our understanding was 1.2.1 could not upgrade directly to 1.3.0, so we did the following:

1. Exported data from current 1.2.1 deployment using builtin export function

2. Deployed new 1.2.2 VM, reconfigured IP settings to be identical to old 1.2.1 deployment

3. Updated 1.2.2 to 1.3.0 through update function

4. Imported data from 1.2.1 export

OK I tried to update from 1.2.1 to 1.2.2 (then added the hotfix attached) and still received the same error. 25% and it says "Failed to import data".

So I updated to 1.3, tried importing again - same error "Failed to import data".

So I can't get our data into the new server yet. 

We do have about 2300 units now trying to onboard though! I really don't want to have to manually put in 70 locations and coords!

Anyone from Cambium willing to chime in?  Is this a known issue?  Is there a work around?  Any way to import data from 1.2.1 into 1.3?

We are having trouble upgrading to 1.3 as well.  We exported the data from 1.2.1 and then tried to import on a 1.2.2 VM.  The export file is uploaded to the server, and then we immediately get a 'Failed to import data' pop-up.  We also tried upgrading 1.2.2 to 1.3, and that gives us the same error.

I just tried upgrading 1.2.2 to 1.2.3, and the import from 1.2.1 still fails...

I managed to get our cnMaestro upgraded to 1.3.  Here's what I had to do:

1. Install OVA of 1.2.2 and upgrade it to 1.2.3

2. Export data from 1.2.1

3. Shut down 1.2.1 VM

4. Extract tarball of export data

5. Created new tarball of extracted export data

6. Imported new tarball

The key was operations.log was showing "ERROR - invalid header" when it was trying to extract the tarball.


Can you send the cnmaestro tech support dump link via private message (you can take the tech dump from manage>server>diagnostics tab)

I can go through our logs as to why it fails to import the new package.

Once we analyse the issue we can surely help you out.




Which browser/OS you guys are using while you upload the cnmaestro tar to update your VM?

Please share the browser details along with OS from where you accessing NOC.

I see few customer could update without any issue and it also passed our test lab. We need all details to analyze it completely.


If you get invalid header, please try using chrome browser to apply the package update.

1 Like


We went through the post and apparently few of you tried to import the data before applying the new package – 1.3.0 and that is one of the issue, which is addressed in 1.3.0.

So just to make sure there are no procedural gaps here, could you please follow below steps while migrating from 1.2.0/1.2.1:

  1. Export the data from existing 1.2.0/1.2.1 installation.
  2. Create 1.2.2 Virtual Machine from 1.2.2-r3 OVA.
  3. Apply On-Premises 1.3.0 package.
  4. Now import the data exported from previous(1.2.0/1.2.1) installation.

In case your import still fails, please share the problematic exported data and cnMaestro tech support dump at .



Hi All

We found some issue with PMP 15.0.1 software upload in latest 1.3.0 release version of On-Premises.

For Customers who are using PMP Devices with cnMaestro On Premises , Please upload the PMP cnMaestro Canopy_15.0.1.tar.gz package in the cnMaestro On Premises version 1.2.2-r3 and then update the cnMaestro Package with 1.3.0-r5 release.

Sorry for the inconvenience.



Using firefox and chrome will never be installed on this computer sorry. 

Is it possible to access your On-Premises from different machine which has Chrome installed?

1 Like

We have fixed the browser issue  on our end and the next package update should work fine.

But for now with the released package 1.3.0, please go with alternative we mentioned.

I had someone with chrome do the import and it did work. 

So the issue is indeed a browser related thing.  Good to know it'll be fixed in the future! 

I'll report any other issues we fine, thanks for the help guys!

Happy to hear that it worked for you.

Please do let us know incase you see any other issue, and thanks again for posting, this help us building our product better.


So far so good.  However it does seem a bit sluggish.  If I give it 2 more processors and some more ram will it utilize it?  I'm also going to throw it on one of the SSD datastores.  Definitely more sluggish.