cnMaestro on Proxmox


Currently have 1.6.3 running on proxmox and I don't recall any issues installing it.  Just convert the ova file to qcow2 and import.

When trying to convert the 2.1.0-r22 ova over to qcow2, I keep getting the following error when converting the disk1 image:

root@pve-dc:~/tmp/convert# qemu-img convert -O qcow2 cnmaestro-on-premises_2.1.0-r22_amd64-disk1.vmdk cnmaestro-on-premises_2.1.0-r22_amd64-disk1.qcow2
qemu-img: error while reading sector 63616: Invalid argument
qemu-img: error while reading sector 63744: Invalid argument

I've tried multiple versions of qemu-img and even a couple stand alone tools from other vendors, and they all seem to choke at the same point.  The disk2 file converts without any errors.

Does anyone have any suggestions?

Proxmox is KVM

I never try cnMaestro in Proxmox, because Proxmox lack of documentation

What I like with Proxmox is quota management.

But cnMaestro run perfectly on Eve-NG

Thanks for the link but one of the steps they do in those instructions is run the same qemu-img convert command that I can't get past because of the following error:

qemu-img: error while reading sector 63616: Invalid argument

So your version of qemu-img is able to convert to qcow2 with these vmdk files?    Could you please let me know which version?


To solve this I actually just re-downloaded the ova from the cambium site and tried again.

Not sure how 1 file inside of a .tar file can be corrupted while the tar file still unpacks properly on multiple machines, yet all were bombing out at the same sector during the qemu-img convert stage.  If the download was corrupt then the .tar file should have given errors.

Defnitely a new one for me...


You wouldn't happen to have step by step instructions to make cnmaestro work on Proxmox 5?

Just follow that, the procedure is similar for Proxmox or Eve-NG

1 Like

Just tried to reinstall cnMaestro 2.2 -on Premises on our Proxmox 5.x cluster and it went smoothly.

For those interested, there is a small tutorial.

1) Upload the *.ova to the Proxmox machine either via GUI (I had to rename this do file to .iso) or via SCP.

2) Untar it: tar -xvf *.ova

3) Create VM with required resources, in my case it was 4GB RAM, 2 CPU's, E1000 ethernet adapter and some storage. Don't start it yet.

4) From the Proxmox console (not the created VM) import now the two disks:

qm importdisk <VMid> cnmaestro-on-premises_2.2.0-r60_amd64-disk1.vmdk <storage> -format qcow2

qm importdisk <VMid> cnmaestro-on-premises_2.2.0-r60_amd64-disk2.vmdk <storage> -format qcow2

It takes some time and there should be no errors.

VMid is the number of your VM, in  my case it was 111.

<storage> is the name of your storage (it could be local or NFS like).

5) From the Proxmox GUI, remove the disk you created when defining your VM, there is no use for it. You will see two unattached disks. On the Hardware option of the VM, click on the disk1 and Edit-Add. The same on disk2. Now you have attached both disks. This should look like this:


It is important to note, that the sequence or id of the disks is mandatory.

Now you can start the VM and continue to configure it.

Good luck!


Worked perfectly on Proxmox 6.  Thanks.

Trying to get this working I am not a linux guru so i am not sure how to convert the files once logged in as root or where to even find the darn file in root.. Thats where I am stuck at..

Do this to solve this issue

1.- Download cnmaestro OVA file.

2.- Upload OVA file into promox server

3.- untar OVA file using this: tar -xvf cnmaestro-on-premises_X.X.X_amd64.ova

4.- qm importovf (ID: ej. 100) cnmaestro-on-premises_X.X.X_amd64.ovf (storage: ej. local-lvm)

Command in my test: # qm importovf 199 cnmaestro-on-premises_2.4.0-r3_amd64.ovf local-lvm

Then just login into proxmox GUI and start de VM.


Spent a few hours trying your method on PVE 7.4-3
Cannot get Ubuntu 20.04 to fully boot.
It is super slow and ends up dumping me out to a BusyBox prompt…