cnMaestro Strange Onboarding Behavior for APs

I have setup within a testing environment the following APs into a new cnMaestro Essentials environment: A E410 and XV2-22H, and a XE3-4, along with an EX2016MP and a EX1010P switches. After adding all the serial numbers for the APs and switches in the Onboarding page, I connected the EX2016MP and EX1010P switches to the Internet, were onboarding and then I moved them into a Site and updated the firmware to the latest recommended firmware version of 5.0.1-r4 for each switch. Then I connected the E410, XV2-22H and the XE3-4 into the EX2016M-P to start off with and then waited for the APs to come up to the Green LED state and then approved them within the Onboarding page. Nothing happened. I double-check the physical connections to the uplink ports to my main router, along with the firewall rules to make sure something was not blocking the APs from connecting out to cnMaestro Cloud. I went to far as to switch out a Spectrum Advanced Wifi Router with another known good router to my Spectrum Internet connection to make sure it was not being blocked. After that, the APs were still listed as “Waiting For Device” in the Onboarding page. The next step I took was trying to troubleshoot just the XV2-22H on the EX1010P which has nothing but the default Switch Group configuration to see what is going on. I was able to manually log into the Web GUI of the XV2-22H and noticed that it was reaching out to the cnMaestro Cloud every 5 minutes or so, trying to resolve the URL, failing and then restarting the process again. Only other thing that was different was that the firmware on the XV2-22H was a newer version then the recommended version within the cnMaestro environment. After double-checking through the EX1010P with a wired laptop connection that I was able to ping the website, I factory reset through the XV2-22H Web GUI the AP. As soon as that happened, the XV2-22H cycled through the reboot process and then was picked up in the Onboarding page by cnMaestro Cloud, the firmware was updated to the recommended and ready to go. I did the same via physically pressing the Reset buttons on the E410 and the XE3-4 which also worked.

Is this behavior typical for the installation process for new APs into cnMaestro or is there something else at play that I missed to make this process more difficult?

I will defer to someone from the cnMaestro team, but it does make logical sense to me Ryan. I would expect this behavior in fact. Once you have chosen to configure an AP as standalone, you should not expect cnMaestro just override it without permission to do so. Thus, if I read it correctly, you did this workflow:

1 - AP was configured as standalone for some purpose
2 - AP was reset to factory default (by UI configuration or reset button)
3 - AP could now be onboarded by cnMaestro

Note this very important future note: we are removing the standalone UI from Wi-Fi 6 APs going forward. The only managed mode they will support is cnMaestro. I realize this will take away a bit of flexiblity, but in truth you should always want an AP in real deployments to be managed. and since cnMaestro Essentials cloud is free, why not use it?

Thanks for the reply back on this and to be clear the following was my workflow:

1 - Added the APs into the cnMaestro Onboarding Page by using the Serial Numbers on the outside of each AP box
2 - Unboxed and connected to the EX2016MP and EX1010P switches to power them up to be ready to be adopted in cnMaestro environment.
3 - Click the Approve All button and waited for them to be onboarded.

The issue was that with the EX switches, after the Approve All, they were onboarded. All the APs were not and stuck at the “Waiting for Device” notification in the Onboarding page. I logged via the Web GUI into each AP to determine if there was some other issue (Bad AP, not getting enough POE power from the switches) which the only thing I noted was the firmware was a higher/newer version then the recommended firmware for each AP in cnMaestro.

Only after I physical hit the Reset buttons on each of the APs, power cycled them, were the APs adopted into cnMaestro successfully. I did not set them up as standalone APs and then tried to adopt them, this was the behavior straight from the box.