CNMatrix firmware update issues (4.6r2)

I upgraded two new TX1012PAC switches to 4.6r2. I popped on a minimal config on each switch before the firmware upgrade.

First one I rebooted with “keep settings” option enabled.
It appears to have scrambled the login. Error I receive is " ERROR: Unprivileged user. Login prohibited"

Second one I avoid this by choosing the option to reset settings.

Do I now have to mess around with a console cable because in their infinite wisdom, someone at Cambium must have thought it’d be a great idea to not put a reset button on these switches?

I hope there’s never a critical issue that requires upgrading these switches remotely

1 Like

Have you tried the default login credentials? I assume you have.

Yep… am working through it with Cambium support.

Ok, so for anyone with similar issues that’s been landed with an older (New) CnMatrix switch that doesn’t have a reset button OR wants to save themselves a truck roll if they lose a password. Basically you have to grab the serial number and onboard the switch to cnMaestro. From there you can factory reset it. In my case had to add some src natting from my workshop setup to get this working. Interestingly a firmware upgrade using cnMaestro worked and didn’t lose settings. I’m not convinced I’d be doing non critical firmware upgrades to these switches out in the field.

As usual Cambium support was great (should be at the price :wink: )