Cnmatrix, how do I apply a static IP? It currently errors out

I have a network of programmed for my test lab with a gateway of .65.

I am trying to program my cnmatrix switch with the following:
Default gateway:

But it errors out as shown in the picture above. How do I fix that?

ERROR: default gateway should be on a directly connected network


have you tried from command line? This could be a GUI error (maybe a bad js?).

ip route

I have not encountered the same error on the switch running 4.4-r3. Please see below.

Verify the setting on the swith via CLI

1 Like

WorkBench-Test# show ip int

vlan1 is up, line protocol is up
Internet Address is
Broadcast Address

vlan4003 is up, line protocol is down
Internet Address is
Broadcast Address

Can you type the command ‘show ip route’ to confirm the setting of default gateway?

WorkBench-Test# show ip route

Codes: C - connected, S - static, R - rip, O - ospf,
IA - OSPF inter area, N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
E2 - OSPF external type 2

S [1/1] via
C is directly connected, vlan1

Hi, the ip address and default gateway look correct in the switch. Is there any problem?

@TamN thank you for responding. I opened a support ticket (337558) and I am working on several configuration issues/bugs now. It appears that Cnmatrix switches just really are not meant to be programmed from the GUI and need to be programmed via the CLI i’m guessing. I’ve ran into a few bugs now that hopefully are submitted.

I am having a very frustrating experience working with these. From the awful UI to the massive POE issues we are seeing I’m not sure these are the switches for us. The Mikrotik switch we are evaluating is much more polished and intuitive. Coming from the Mikrotik/Netonix/Ubiquiti world, I’m not happy with the performance of these for the premium price.

Hi JoeG, I am sorry to hear you are facing obstacles with our switches. I would like to have a call with you to understand your concerns, and hopefully to clear up/resolve them. Appreciate very much for your time and feedbacks. Please let me know when and how I can reach out to you. My contact is

Best Regards


Thanks @TamN e-mail sent

I just want to update this post. @TamN went above and beyond and guided us through a remote session. Once I used Cnmaestro to configure all the settings everything works as expected. Great support from Cambium.


Thank you, Joe. We are continuing to improve our Web GUI to make the configuration more intuitive. We appreciate your feedbacks and take them seriously. Looking forward to working with you again.

Best Regards,

1 Like

It’s confirmed it was a GUI’s bug?

Hi, it is rather a kronwn limitation in the IPv4 Quick Start. The configuration applies to the default VLAN 1. Unlike a L-2 switch, cnMatrix supports inter-vlan routing and dynamic routing and hence there can be multiple vlan subnets. In the future release we can add ability to specify the management vlan to apply the IP setting on.

1 Like

I keep running into new things with these switches… When configured from Cnmaestro it appears they may not be getting a write mem after a sync… I have a switch only configured from cnmaestro and synced but if the switch reboots it looks like it reverts to last config. @TamN I’ll get a ticket opened and cc you.

HI Joe,

It takes the switch ~3 mins to permanently save the config into local flash memory following a successful config sync. This delay is to ensure the new config does not cause the loss of connectivity for the switch,


@TamN It was sync’d for several days. After a reboot it reverts its static ip to DHCP and it loses its cloud registration information. I can reproduce this on demand. I’ll open a ticket now and send you an e-mail.