cnMatrix VLAN, Access/Trunk ports config with Cisco core router & switch

Hi,
i have 4 cnMatrix switches connecting to 4 PTP450i that making ring topology around my network, however, i have Cisco core router and Cisco core switch that connecting to this topology.
i configured VLANS (VLAN IDs: 1, 20, 30 and 40) with 802.1Q standard on both Cisco devices with trunk ports that will transfer all VLANS across the network with following IP plan:

- VLAN 1: managment VLAN, 10.1.10.0/24

- VLAN 20: CCTV VLAN, 10.1.20.0/24

- VLAN 30: Voice VLAN, 10.1.30.0/24

- VLAN 40: Internet VLAN, 10.1.40.0/24

i need to configure trunk ports and access ports on all switches to make this setup works.

so appreciate your support in achieving this goal..

Also, i have one more stupid question, how can i change the IP address of cnMatrix switch to make it within my management network range (10.1.10.0/24)?

Many thanks in advance

Jop,

        First thing is make sure you are running the latest code of software for the matrix switches. the syntax is similar to Cisco in the CLI. Below is an example of how to set VLAN 1 IP Address on the switch via CLI.

cnMatrix(config)# interface vlan 1

cnMatrix(config-if)# ip address 192.168.1.10 255.255.255.0

cnMatrix(config-if)# no shut

cnMatrix# write startup-config

We have documentation on our support site as well for the CLI/GUI commands.

Hi Justin,

thanks a lot for your response, i made sure that all equipment updated with latest SW release, also after reading most of your documentations and resources i noticed that syntax is very close to Cisco commands, but trying all the facts above; i couldn't configure switches for basic functions, however, talking about Cisco, i would do the following:

Switch(config)#int VLAN1 

Switch(config-if)#ip add 10.1.10.5 255.255.255.0

Switch(config-if)#exit

Switch(config)# ip default-gateway 10.1.10.1

also, with VLANs and ports:

- define VLANs:

Switch(config)#int VLAN 20

Switch(config)#int VLAN 30

Switch(config)#int VLAN 40

-Trunk/Access Ports:

Switch(config)#int gig 0/1

Switch(config-if)# switchport mode trunk

Switch(config-if)#int gig 0/2

Switch(config-if)#switchport mode access vlan 20

Switch(config-if)#int gig 0/3

Switch(config-if)#switchport mode access vlan 30

.

.

so, the point is, can you please help me in the basic tasks i want to do with my switches as i'm still new to Cambium products?

thanks again, and looking forward to hear from you

Hello,

Here are the CLI commands to configure cnMatrix:

Switch(config)#int vlan 1 

Switch(config-if)#ip add 10.1.10.5 255.255.255.0

Switch(config-if)#no shut

Switch(config-if)#exit

Switch(config)# ip route 0.0.0.0 0.0.0.0 10.1.10.1

-Create VLANs

Switch(config)#vlan 20

Switch(config)#vlan 30

Switch(config)#vlan 40

-Trunk/Access Ports:

Switch(config)#int gig 0/1

Switch(config-if)# switchport acceptable-frame-type all

Switch(config-if)# switchport mode trunk

Switch(config-if)#int gig 0/2

Switch(config-if)# switchport acceptable-frame-type untaggedAndPrioritytagged

Switch(config-if)# switchport mode access

Switch(config-if)#switchport access vlan 20

Switch(config-if)#int gig 0/3

Switch(config-if)# switchport acceptable-frame-type untaggedAndPrioritytagged

Switch(config-if)# switchport mode access

Switch(config-if)#switchport access vlan 30

2 Likes

Below is a quick example. Depending on what ports you want to assign etc. Hope this helps.

VLAN creation and port assignment:

•cnMatrix(config)# vlan 20 – create VLAN 20 and make it active

•cnMatrix(config-vlan)# ports add gigabitethernet 0/2 untagged gigabitethernet 0/2 – assign port Gi 0/1 to VLAN 20

•cnMatrix(config)# vlan 30 – create VLAN 30 and make it active

•cnMatrix(config-vlan)# ports add gigabitethernet 0/3 untagged gigabitethernet 0/3– assign port Gi 0/3 to VLAN 3

•cnMatrix(config)# vlan 40 – create VLAN 40 and make it active

cnMatrix(config-vlan)# ports add gigabitethernet 0/4 untagged gigabitethernet 0/4 – assign port Gi 0/1 to VLAN 40

PORT creation:

•cnMatrix(config)# interface gigabitethernet 0/(1) -- Port you wish to assign

•cnMatrix(config-if)# switchport  acceptable-frame-type untaggedAndPrioritytagged  - the acceptable frame type has to be configured  to untaggedAndPrioritytagged the access port prior to actually make it an access port

•cnMatrix(config-if)# switchport mode access

•cnMatrix(config)# interface gigabitethernet 0/(2) -- Port you wish to assign

•cnMatrix(config-if)# switchport mode trunk – will be automatically added to the existent and newly created VLANs

1 Like

thanks a lot, really appreciate your help, i guess this config will work..

Hello,

I tried this configuration and it works very well, thanks a lot for your help.