cnPilot and Smart TVs connectivity issue (SOLVED)

The problem I ran into was that my Smart TV and Roku Stream stick that were losing connecting to the Access Point.  In my case I was using the cnPilot e430w, but this can happen with nearly all of the products.  What I discovered with some investigation is that many of the WIFI chipsets used in these streaming devices can't channel scan like the WIFI in my laptop or cell phone can.  This means that as I had my WIFI configured to scan every night at midnight and select the cleanest channel, the TV & Stream Stick could not follow the change.  I'd have to go into the configuration and re-setup the connection.  My solution was to disable the nightly clean channel scan and just run on the best channel I could find manually.  This overcomes the weakness in the TV & Stream stick WIFI, and if conditions in the band change I'll just have to rescan and move everything manually.


We’ve found that the following settings results in a more stable E400 experience with less disconnects:

Under Configure -> Radio:

Channel: Automatic
Channel Width: 20MHz for 2.4, and 80MHz for 5GHz
Airtime Fairness: Disabled
Mode: gn for 2.4, and nac for 5GHz
Auto Channel Select: On-Startup (but I’m curious to experiment with the ‘No Clients’ and ‘Scheduled’ options)
Off Channel Scan: Disable OCS
Auto RF: Disable Auto RF
Interference Avoidance: Disable Interference Avoidence
Enhanced Roaming Tab: Enable, threshhold set to 10dB SnR (for both 2.4 and 5ghz)

All other settings are DEFAULT

Under the WLAN/SSID:

Drop Multicast Traffic: Enabled
UAPSD: Disabled
QBSS: Disabled
Band Steering: Normal
Fast Roaming: ALL DISABLED

All other settings are DEFAULT

1 Like