cnPilot Domain Name Issue

Hi we’ve been noticing an odd issue at 2 sites with aps randomly falling off cnMaestro.
The sites have the corporate $ setting set as the Domain Name in networking configuration tabs.Sites where we don’t have this issue don’t have that option ticked.

What we’ve seen at times especially at busy/high load times that the aps get kicked off CNMaestro trying to resolve an non existent AAAA record for whatever reason.All these sites are v4 only which makes it even weirder.

09:27:59.222140 IN: IP X.X.X.X.56717 > 29139+ AAAA?$ (58)
09:27:59.225044 , OUT: IP > X.X.X.X.56717: 29139 NXDomain 0/1/0 (141)

Once the NXDomain is received the APs will then go offline from CNMaestro Cloud, until a random time it tries to go back and resolve the correct

Checking if someone here has seen the same issues perhaps ?

Sometimes you didn’t enter the address manually on cnpilots?

The second idea is that somewhere in resolv.conf on the DNS server there is a domain which, if it queries the existing DNS, gets attached to all things.

What is it doing with DNS? Linux ? any other solution?

I had checked on the aps and the address isn’t set but none of my other cloud sites seem to have it set as well.
I tried removing the domain name on the ap’s which has fixed this weird issue of the subdomain but the aps themselves still lose connectivity with cnMaestro on a regular basis. End to end connectivity to I’ve checked for hours while the aps are going down/up and doesn’t seem to be an issue.

On the DNS side we’ve tried both the on premise firewall dns as well as the regular dns.
On the firewall side we’ve switched off atp/ips for those mgmt subnets and still getting these issues.

I think I’m going to have to log a ticket again on this.Chucking out the firewall or changing the network design seems to be the only real options I can still try. Kinda bizarre the only things that have internet connectivity issues to cnMaestro are just the aps.Switches in same vlans have no issues.