cnPilot R200 issues connecting Apple ipad, iphone, laptops to WIFI or LAN

In ticket #133152 I identified that my cnPilots R200 have an issue with 4.3.2 and 4.3.3 firmware where Apple devices (two ipads, 2 iphones, and a Apple Laptop Pro) all had difficulties acquiring an IP and/or getting online.  Additionally, we had problems with an Android phone connecting to the wifi too. 

The Laptop was wired and wireless and we had the same issue either way.  They would pull an IP for 5-10 seconds then lose it on 4.3.2.  On 4.3.3 we couldnt' even get them to pass the DHCP Offer state.  However, on 4.3.1 and lower we were able to connect the devices just fine.

Also, this issue only happened on routers with serial numbers that start with 400xxxxxxxxx   The router devices that start with WFS worked fine even on 4.3.2. and 4.3.3 firmware.

Our solution was to drop routers with serial numbers starting at 400xx to 4.3.1 or lower and they worked fine.  I was asked by Cambium to post an update here so that we can all get updates on when the fix is released.


I've had two more clients call in saying their apple devices have issues getting online/pulling a valid IP address.  It still seems lowering to 4.3.1 is the solution.  Both of these clients serials started with 400xx too.

 I'm going to set up a cnPilot R200 in my lab and duplicate the problem and send the log/config files and anything else you want to look at.

This past week, we spent considerable time upgrading all of our R-200 routers on our networks to the latest firmware (Version 3.3.3-R4) - to get the router's SpeedTest function to work through our OnPremises cnMaestro.  99% of the uploads were performed through our Onpremises cnMaestro (Version 1.5.1-r8)

As has been previously posted in this forum by various folks, the Speedtest function has been sorely needed every since the Cambium routers were introduced to allow us to test the actual throughput from each router through the Cambium ePMP radios to the OnPremises cnMaestro server. 

Within 1 day, we started getting calls from several customers saying that they could not log with some of their Wireless devices to their existing R-200 routers.  Not good....

To make sure that those particular customer's R-200 routers received a legimate "load" of Version 3.3.3-R4 in their routers, we manually uploaded Version 3.3.3-R4 in their routers again.  

The wireless device log in problem still existed.

To get us out of trouble, we sent new R-190W routers out to their locations and had them change them out.  For what it is worth, all R-190W routers had been previously upgraded with Version 3.3.3-R4. 

After changeout of the R-200 routers with the new R-190W routers, each customer could then connect to the R-190W with all of their wireless devices. 

This problem needs to be investigated by the Cambium Team. 

I am fixing to be out of town for a week or so. 

When I get a back, I will try to investigate the bad R-200 routers. 

Hi Danny,

I assume you are referring to 4.3.3-R4 firmware.

I shall get this checked and get back to you.




Upfront we are not seeing any issues, and the iphone was able to connect wirelessly (get IP in my case and access the internet). We will also try with other clients mentioned. 

Can you please export and send us the R200 config.

Is the device setup in default NAT mode or in bridge ?



We are having smilar problems. Installed 2 new cable internet customers with R200's connected to them.

One (400 version) worked for 15 minutes (4.3.1) then stopped. Playstation could not connect to inetrent, or iPhone or Laptop. Logged onto R200 and could not ping anything but WAN IP looked right. Connected laptop directly to cable modem and internet worked. Replaced with new R190 and all was OK. Bench tested modem behind a router on Cambium radio and no fault found.

Second customer nothing worked. Again could not ping out from the R200. Replaced with nrew R190 and internet worked.

Third (400 version) unit was working fine behind cable modem at my office until upgraded to 4.3.3. Then no device could connect wired or wireless. Downgraded to 4.3.1 and all was OK.

Hi Dave,

As I mentioned in my last post. We tried to verify the issue in our lab, howeer we did not see any problems connecting apple clients (or in getting IPs).  It would be helpful if you can provide some more details to see if there is an issue.

Can you please send the config from the AP when seeing the problem and device logs to my email address



Yes, the others and I that have reported the problem are referring to the 4.3.3-R4 Firmware. 

I have been out of town for a few days, however am back for 3 or 4 days. 

I am fixing to hook up the R200 router from the first customer that called in and complained.  The Serial Number of his router is 400FRG0LHJMF. 

To get him up and running, we swapped out his R200 with a new R190W, (with 4.3.3-R4 installed in it).  I talked to him this morning and confirmed that the new R190W is working like it should.

When he called in, he was complaining that he had several wireless devices that would not stay connected.  He told me that the wifi connection problem started a couple of days prior to his call.  That was the day that we upgraded everyone to Version 4.3.3-R4.

When I talked to him this morning, I asked him specifically what devices he was having trouble via Wifi. 

He said that he had two Apple devices that would not connect. 

He also said that his wife has a HP laptop that would not stay connected, as well as he could not stay connected on his Microsoft Surface Pro. They would show that they were connected, however when they went to check their email or browse - it would kick them off.

We are in the process of downgrading all of the R200 routers with Serial Numbers that start in 400 back to Version 4.3.1, until you figure out what the wifi problem is 4.3.3-R4. 

Ashutosh, I  just emailed you the files that you requested from a R200 router with 4.3.3-R4 that has the problem. 

If/when we run across the issue again I will gather the export from it.  Right now, we've deployed the last of our 200 series routers and have already downgraded the firmwares on the one's having issues since they're in production now.  Our new shipment are the white replacement routers R190's.

Hi Danny,

I received the files and we are investigating further. Shall get back as soon as I have some updates for you.




 we have received sample configuration from Danny. We are investigating to find the root cause and shall keep you posted.



Hi Danny,

Was just going through your config. Is there are reason you are sticking to WEP and b/g only mode ? When we tried in our lab with apple clients we tried with b/g/n and WPA2PSK. Shall load your configuration and perform the test again in the mean time.

By the way how does it help, using the Operatin Mode : "Basic Mode" for you ? Just a curious question. (not related to the issue at hand)



Hi Cason, 

Are you also using b/g mode and/or WEP for wireless security in your configuration by any chance ?

I also want to know what is your standard config on the device. Please share with me  via my email provided earlier.

Some questions:

Is your R200 WAN configured in Bridge Mode ?

If so, are you expecting clients to get IP from an external DHCP server.

If so, do you have the local DHCP server disabled ?

Just thinking of a possibility that you have 2 DHCP servers playing in. If in bridge mode we can keep the local DHCP server disabled and let the clients get IP through the external DHCP server behind the WAN.




I have an R200 (S/N 400...) sitting in my "to RMA" pile. The customer would have dropouts where no devices could reconnect to the router and everything would stop working. Eventually I just replaced it with another R200 (S/N WFS...), and everything works fine. Looking back at their logs, all of the devices were Apple devices.

Configuration was very close to defaults using WPA2, NAT, local DHCP, etc.

I use B/G/N mixed mode, WPA-2 passphrase.  We configure PPPoE for our WAN type using NAT on the LAN side.  They're not in Bridged mode.

The Routers get an IP from our DHCP relay server which gets them online so they can access cnMaestro website for provisioning.  After they get their provisioning they switch over to PPPoE.

The attached customers pull their IP addresses from the cnPilot R200's local DHCP server (

We leave most of the defaults on when it comes to wifi, just change the SSID and WPA passphrase.  We've tried switching channels, from 20/40 to just 20... and from short preamble to long preamble but the solution continues to be replace it with a WFS model.

Any progress?


We have been trying to recreate this issue in our labs , but so far all clients are able to connect well. Is it possible to have a remote session (Teamviewer) to get some insight. I am located in IST timezone. 

In the mean time can you try installing the 4.3.3-R4 again and factory reset the box, then try to connect the said clients to the default SSID / psk ?

NOTE: Please export/backup your config to be able to restore to original state later before performing factory reset.



Ashutosh, when I get back into town in a couple of days, I will hook up one of the R200’s that had the problem and let get into it.  

Still has 4.3.3-R4 in it from when it wouldn’t allow various items to connect to its Wifi.  I will PM you after I get it connected.

Ashutosh, I am emailing you the configuration and the syslog files from another R-200 router with a Serial # starting in "400" that has the same problem of not allowing wireless devices to connect to it. 

As with the other R-200's that we have seen, this one has the same problem.

It was running 4.3.3-R4.  We downgraded it to 4.3.1 this morning while they were on the phone and the R-200 allow them to connect their wireless devices back to the 2.4 Ghz Wifi.