CNUT on Linux

dear Experts…

I already successfully install CNUT 1.1 on Slackware 10.0 (kernel 2.6.7), j2re-1.5.0, everything seems okay but when i try to upload Canopy707_DES.pkg to my 5200BH, there is error said “failed to load package:/home/user/CANOPY707_DES.pkg”. When i try to discover my stuff, everything okay n i can get info about my stuff (Type, ESN, Sofware Ver, HW/FPGA. etc). I can load packages well on menu Update–> Manage Packages.
I suspect the packages was corrupt n i try to update via CNUT on windows XP n i successfully upgrade my canopy.
I want to ask why i can’t upgrade the canopy with CNUT on Linux?


I have been able to reproduce the same error on gentoo and debian. I cannot find a fix to the issue.

I try with Mandrake 10.1 (2.6.3-mdk), CNUT was successfully working. I already contact the Canopy Support Team n the answer is very unsatisfied :-(, they only said “CNUT only support RH 9 or RH ES 3.0” without any explanation…
I try to ask what the crucial packages on “RedHat Flavour (such as Mandrake)” that influence to CNUT… n they answer the same!!
I guess, CNUT only work with Java that bundled on setupCNUT.bin, I try extract setupCNUT.bin n install Java that bundled on setupCNUT.bin individually on my Slack machine n the result is same… so my guess is wrong :smiley:

Any comment?

This is a major issue with me as well. To me, Redhat is the last distribution to use… and I have Debian machines that are eight years old (and working great), that I have no intention of changing out.

Redhat 9 is old, moldy and disfunctional now.

I had this same problem. What I discovered was that my perl installation did not have ithreads compiled in. Once I recompiled perl with ithreads, I was able to upgrade my equipment.


Is working for me under Debian Etch. Try to download the file again, or check your java version.

My goals are to install motorola canopy network updater that is designed to be ran on redhat linux my machine has ubuntu on it right now.
when i tried to install the updater it informed me that i needed java and perl running.
i did get java installed, and that installation seemedf to be okay, but i cannot really verify this as i am a complete newbie to this.
then i proceeded to try to install perl and it was a tar file.
i found some basic directions and followed them and it seemed that perl was installed.
the network updater still won’t install and says:
working dir /usr/local/canopy/networkupdater/perlLib/Archive-Tar-1.00
internal error message

What is up with this…any insights into this issue most appreciated
Does anyone know of step by step install instrutions for this and if I got the correct installs?

:roll: :roll:

With ubuntu is easy.


sudo aptitude install sun-j2re1.5 

And then run de CNUTinstaller.