CNUT socket write error


I have been using a really old version of CNUT with PMP450 for a long time and finally decided it was probably a good idea to upgrade. So I un-installed the old version and thne downloaded a fresh copy of version 4.10.4

Now I can't seem to upgrade anything at all, have several SM's on the bench here and verified this on a brand new AP as well. If i try to upgrade something SM or AP it gives the following response:

"11/14/16 21:08:37 WARN    Host:;ESN: 0A003E47E7DF;Message: Failed to upload file 5x_cat120.img, Connection reset by peer: socket write error (SITE= No Site Name)

Does anyone know why this is happening? Doesn't seem to matter if its AP's or SM's.

Oh BTW i am trying to upgrade to version 14.1.1 and also tried several older versions back to 13.4 and also the newest 14.2.1 and still getting this error.

Same here. Windows 10 Pro 64-bit. CNUT 4.9.18 works fine. Just rolled back to it on my workstation. I'm thinking this is a problem with the bundled CNUT Java.

OK i un-installed version 4.10.4 and re-installed and still no luck. Then I un-installed and installed the old version again which is 4.8.1 and its working now! One noticeible difference between the two installs is after i in-stalled the old version and then started the program the windows firewall popped up asking me to allow some JAVA thing related to the program to run which it didn't do with the new version. So maybe if i had disabled the windows firewall and tried running with the new version it would have worked. I am running Windows 7

Can confirm latest CNUT is borked as i rolled it out to all my installers with 14.2.1 for updates, and all had same issue... had to roll them back to an older CNUT to get it to work

I confirm this: I had a AP 450 wth 13.2.1, I have to downgrade CNUT to 10.9.18 to upgrade it to 15.0.1

SocketException:Connection reset simply means that a TCP RST was received. TCP RST packet is that the remote side telling you the connection on which the previous TCP packet is sent is not recognized, maybe the connection has closed, maybe the port is not open, and something like these. A reset packet is simply one with no payload and with the RST bit set in the TCP header flags.

The following are possible causes for the error:

  • More commonly, it is caused by writing to a connection that the other end has already closed normally. In other words an application protocol error.

  • A Reset (RST) packet is received from a remote machine and interrupts the established connection. The sent RST packets may indicate that the TCP packets sent are not recognized, a connection between the local and remote machine is broken, or a particular port is closed and is not allowing for communication.

  • The TCP (Transmission Control Protocol) socket is closed because the socket received a close command from a remote machine.

  • The other end has deliberately reset the connection. It is rarely happens, and generally incorrect, for application software to do this, but it is not unknown for commercial software.

  • It can also be caused by closing a socket when there is unread data in the socket receive buffer.