Complete walkthrough of CNS 1.3 installation on Centos 6.7

I couldn't find any one source for a complete installation of CNS server on Centos 6.7 and apparently it varies from version to version, so I ran into one problem to the next but finally figured it out...

It took me a while to find all the in's and out's, but it's working pretty well now.

I'm sure there are other ways to do it, but this worked pretty seamless for me.

Install CNS 1.3 / Centos 6.7

Notes/FYI:  anything --# is run from the terminal screen

 - System / add-remove software / find and add 'dos2unix'

 - Browse to /etc/hosts and update host file with server information

 - Download linux installation from

 - Go to download folder and right click on the file / permissions and check 'allow executing as program'

 - Double click and go through the installation process

 - Confirm installation and services running --# service cnsapache status / service cnspostgresql status / service cnsserver status

 - Now update the local firewall (if port 80) --# iptables -I INPUT 5 -i eth0 -p tcp --dport 80 -m state --state NEW,ESTABLISHED -j ACCEPT

 - Save IPTables  --# service iptables save

 - Confirm port is open  --# iptables -L

Now you should be able to go to the http://serveraddress and the console should come right up...

Hope this helps anyone else trying to get this to work.




Hi Ryo, I followed your steps but the cnsserver service does not start.
what am I doing wrong?

I installed a fresh CENTOS 6.7 64 Bit
I installed dos2unix and I modified /etc/hosts as installation manual says
I executed the last CNS install file (, The installation script finished without errors. When I check the services:

[root@CNS ~]# service cnsapache status
apache not running
[root@CNS ~]# service cnsapache start
httpd: Syntax error on line 125 of /opt/cnsserver/stack/apache2/conf/httpd.conf: Cannot load /opt/cnsserver/stack/apache2/modules/ into server: cannot open shared object file: No such file or directory
/opt/cnsserver/stack/apache2/scripts/ : httpd could not be started

It seems that the library path is incorrect, I added "/opt/cnsserver/linux/apache2/lib/ext_lib/" in export LD_LIBRARY_PATH on the /etc/init.d/cnsapache script.

This worked:

[root@CNS ~]# service cnsapache start
/opt/cnsserver/stack/apache2/scripts/ : httpd (pid ) started
[root@CNS ~]# service cnsapache status
apache is running

Let's go on:

[root@CNS ~]# service cnspostgresql status
pg_ctl: server is running (PID: 2883)
/opt/cnsserver/stack/postgresql/bin/postgres "-D" "/opt/cnsserver/stack/postgresql/data"
[root@CNS scripts]# service cnspostgresql stop
Stopping PostgreSQL 9.3:
waiting for server to shut down.... done
server stopped
[root@CNS scripts]# service cnspostgresql start
Starting PostgreSQL 9.3:
waiting for server to start.... done
server started
PostgreSQL 9.3 started successfully
[root@CNS scripts]# service cnspostgresql status
pg_ctl: server is running (PID: 3378)
/opt/cnsserver/stack/postgresql/bin/postgres "-D" "/opt/cnsserver/stack/postgresql/data"
[root@CNS scripts]#

Postgres is ok, I see an error with the database.json for cnsserver service:

[root@CNS scripts]# service cnsserver status
cnsserver dead but subsys locked
[root@CNS scripts]# service cnsserver start
cnsserver dead but subsys locked

[root@CNS scripts]# /opt/cnsserver/scripts/
2015-12-14 11:09:53,557 ERROR EncryptionUtil.decrypt(): javax.crypto.IllegalBlockSizeException: Input length must be multiple of 16 when decrypting with padded cipher
2015-12-14 11:09:53,560 ERROR DatabaseConfigData.loadDatabaseSettings(): Problem loading the database configuration file (../conf/database.json): java.lang.NullPointerException
java.lang.String.<init>(Unknown Source)<init>(<init>($ConnectionPoolHolder.<clinit>(
2015-12-14 11:09:53,561 ERROR ServiceLauncher.main(): Unable to connect to the database.

Any suggestions?



Could it be permissions?

I installed everything under the root account.

I had to reinstall the other day and used 6.7 and it installed without issue.

Would you please show steps how to install in Centos7 in command mode