Configuration push issue

HI everyone,

I'm doing some test using Cnmaestro, after successfully onboarding my first E400, i get an error message when I try to push the configuration, as shown below, could someone help me please?

After making some changings I managed to get "only"  invalid IP Address -.-


P.S. my test set consist of my home modem/router, connected with 1 LAN port to my pc and with another LAN port connected to the E400

  • It seems, there is an invalid character entered in hostname.
  • In AP hostname, following characters are supported
    • 0-9
    • A-Z
    • a-z
    • '-' [Beginning and end of string this character is not allowed]

Please use string with above characters in hostname and let us know if you still have issue.

1 Like

Thanks, this evening I will try;

however in the last few days I got the invalid IP address error (the invalid character disappeared), but I do not know why since I didn't touch the IP address

Thank you very much again for your reply

Unfortunately I keep having the invalid IP address message when pushing a config, don't know why

The strange thing is that logging into the E400 using GUI the logs show that some changes has been made, but for example the radios still do not work; I think that parameters such as name and other are pushed successfully but not others, like radios settings

Could you please provide me version no. of  cnMaestro and AP?

Could you please email me tech-support of AP at

Thank You.

I've just emailed what you have requested.


Hi, any solution for this isue? i have the same issue too for on-premise cnmaestro version 1.4.0 

We are working on this and hopefully it will be part 1.5.1 cnMaestro release.

With Regards,

I had the same issue with the cnMaestro cloud (Version 1.6.3-r1 according to Cambium web site) and got this error when trying to set DHCP / VLAN gateways for 2 x SSIDs across 2 x E410 APs. I ended up logging in locally to the problem AP and removing the VLANs, then removing the same from the cloud config, then setting it back up from scratch again and it came right.


Please confirm if you have enabled DHCP on both VLAN interfaces.

Thank You.

Hello there,

I have the same problem, 16 accespoints with same messages " Not In Sync Sync Configuration Configuration failed: interface_vlan:Invalid IP address string", 


020-05-04 04:39:00 475 wifi.c:1768:platform_set_cns_connection_state: New Connection_state Connected(6)
2020-05-04 04:39:00 475 wifi.c:294:platform_set_config: Object based configuration update initiated
2020-05-04 04:39:00 475 wifi.c:302:platform_set_config: Bad config request [interface_vlan:Invalid IP address string]
2020-05-04 04:39:00 475 device-agent.c:1572:handle_cns_msg: Sending MSG_CONFIG_UPDATE_FAILED to cnMaestro
2020-05-04 04:39:01 475 log.c:207:start_cns_logging: Send log history (10 lines)
2020-05-04 04:39:00 475 wifi.c:1307:set_log_level: syslog severity=7

I 've  update firmware to last version already, also i've made factory reset, delete all wlans, load config file from working in-sync APs, ..   16 not in sync and 6 sync... all the same model cnPilot e410.

thanks for your help.

Eduardo Montoya.


Hi Eduardo,

Could you please invite me to your cnMaestro account if APs are on boarded to cnMaestro cloud.

My email:

Best Regards,

Gupta Bobby

Hi Gupta Bobby,

you got it,


Hi Gupta Bobby, 

Do you have time to check this problem?


Eduardo Montoya

Hi Eduardo,

I have sent an email to your email ID, here is the content.

Thanks for inviting me to your account.

Looks like VLAN 16 interface when during creation got corrupted.

Try following 2 options and let me know the results:

  1. Try deleting VLAN 16 on existing AP group save the config and recreate VLAN16 interface and save.
  2. Is it possible to create a test AP group manually with all config same as current AP Group and move one AP to this new test AP group.

Best Regards,

Gupta Bobby | WiFi Solution Architect | Contact Us

Cambium Networks

Hi Gupta, 

I did it, I've delete it then when I try to push the new config I have the same error. I'll try the 2nd option, is it posible to clone that group?.



Hello again,

I did it as you ask me,  I've cloned AP-group "oficinas-Bogota", and claim an access-point to this group, first I tried to push the same configuration with all my vlans,... I get the same error message. So Then i try to push the config only using 1 vlan,  the one that actually works CCB-CORP from the clonegroup.. .I get the same error message, im attching to this message an image. 

I want to be more specific, rith now the problem is that vlan 16, is not working good.. all my clients connect and lost connections in random time, or sometimes they connect to wi-fi without internet access. 

All this problems start 2 or 3 week ago when the building power go out. I hope this is not a hardware damage, is it posible?.


Eduardo montoya

Pd, Im still learning english

Hi Eduardo,

I have deleted VLAN 16 and recreated it and pushed the config on the clone AP group and also on the actual AP group, currently all APs which are online are In-Sync.

Let me know if you need any further assistance.

Best Regards,

Gupta Bobby

Hi Gupta,

Thanks for your help, I'm running test and I'll let you know the result, tnks.


Eduardo Montoya