configure cnMaestro with ssh ePMP1000

Hello, I could help set cnmaestro for ssh? I have tried using the following commands and I could not.

config set cambiumCnsServAccountID xxxxxxx
config set cambiumCNSDeviceAgentPassword xxxxxx
config save
config aply

After executing these commands, in the SM says Cambium-ID Not Configured.

I am doing something wrong? any parameters are missing?


Hi cowper

What  version of software  you are using?

As I can see you missed some parameters. You can see all needed parameters in my example below

ePMP1000_c6f915>config set cambiumDeviceAgentEnable 1
ePMP1000_c02071>config set cambiumDeviceAgentCNSURL <your URL>
ePMP1000_c02071>config set cambiumCNSDeviceAgentID mykola
ePMP1000_c02071>config set cambiumCNSDeviceAgentPassword 12345678
ePMP1000_c02071>config save
ePMP1000_c02071>config apply

Thank you.


Hi Mykola, thank you. The version is 2.6.2.


I'm doing these commands and on some devices I need to issue a reboot for it to work and others it does not lead to me being able to onboard - the device in question says the AP is onboarded and doesn't do anything with the on prem CNM.



Sergiu told me people check this forum...

I will ping somebody on this one Josh... it may be that because this is a "solved" thread, fewer eyes are seeing this. (Plus it seems like a cnMaestro issue maybe, not necessarily the ePMP, so another complication).

I will find someone that can look into it...


I tested the following ePMP SSH commands on a device.  It worked as expected.  On the device that I tested, a reboot was not necessary.  After executing the following commands, I could see this ePMP SM waiting for approval in the cnMaestro Onboarding queue.

config set cambiumDeviceAgentEnable 1

config set cambiumDeviceAgentCNSURL

config set cambiumCNSDeviceAgentID KREDDUM_CNSNGQA

config set cambiumCNSDeviceAgentPassword <my_onboarding_key>

config save

config apply


I tried this on an ePMP SM running software version 3.5.1.  cnMaestro was a version of 1.6.3.  


If  you enter the same information in the ePMP device UI, does the device then appear in the onboarding queue?  See Configure --> System-->cnMaestro from the ePMP device UI.


If you continue to run into issues, can you enable the ePMP device syslog and look for "device agent" related messages.  


As a side note, there is another thread detailing SNMP OIDs for the same purposes.







1 Like

Tried a few more manually and they seem to be working now...maybe watching the syslog is scaring it into working.

I tried a couple units with the GUI before the post and those worked.  I'm looking to do many radios with command line scripts, though, and the radios I tried right before my post didn't work.

I'm pretty familiar with the SNMP OIDs and that guide.  Look at the author of it ;)

1 Like