Constant script errors, Google maps, Windows 10, V4.4.0

Hi, there is a google-maps related script error, possibly limited to the PT-br language settings:

everytime i try to move over the map // change zoom . 

It only happens if i have active links in the project.

(if i have only the network sites, but not linked, there are no problems). 

Is this a known issue, or there are any further information i could provide to help fixing it?



We noticed the error last week and we have updated the map so that it uses an older version of the Google Map API. However, you may need to force the embedded web browser to refresh if you want to see the changes. To do this:

- Start LINKPlanner and create a new empty project.

- Right-click anywhere on the map in the Google Map view and click Refresh or simply press the F5 key.

- Toggle the Google Map view off and on using the Google Maps command under the View menu.

Let me know if you still have problems.



1 Like

Works fine now, Thank-you!!

Dear Sir,

I followed the instructions, but the problem remains, what can I do?

Windows 7 64

Unfortunately Google released a new version of the map API yesterday which means that the version used by LINKPlanner is no longer available. The new version seems to cause errors when running in the embedded web control inside LINKPlanner.

We'll try to find a fix or temporary work-around for the issue and update this thread when we have one.



If you try the steps again (refresh/toggle the map view) then it should be working as expected now. 



NOt work for me!

Can you provide a bit more information?

- What version of Windows, Internet Explorer and LINKPlanner are you using?

- Have you refreshed the page before toggling the map off/on?

- Have you tried clearing your cached browser files?

- Are you seeing the same error message or a different message?



OS windows 7 32 bit
IE 10
I did all the steps and the same error still appear

Can you paste in the exact error message that you are seeing? That will tell me which version of the Google Map API your browser is trying to load.

How can I know which API version I have?


Unfortunately the image is too small for me to see. If the error is similar to:

then the map is using v3.25 of the API. It should now be using v 3.26, so you should see something similar to:

Unfortunately I only have access to Windows 7 with IE 11 at the moment so I am unable to recreate your environment.

You can also try visiting in Internet Explorer. This is a modified version of the map code which just displays a site and an access point. You can use this to test your Internet settings outside of LINKPlanner.


I also still get the script error. Have tried everything and still get the same problem


From the error that you posted it appears as though your computer is still trying to pull down v3.25 of the Google Map API rather than the correct version - v3.26.

Check this link - in your version of Internet Explorer. It should open without an error. If you are seeing errors then check your version of Internet Explorer. It should work with IE10 and above, but I've only got v11 to test with.



Encontre la Solucion, tenia windows 7 con IE 8 y el error persistia, luego instale IE 11 y se corrigio el error!!

issue persists. windows 7

Windows 7 is no longer supported by Microsoft so Google have probably stopped supporting it for Google Maps. If you want to use the embedded Google Map you will probably need to update your operating system to a recent version.



It was working in Windows 7. I upgraded Linkplanner and began encountering issues. Reinstalled previous version but still issue persists.

1 Like

I've also replied directly to the email that you sent. Anyone else experiencing similar issues should read

You must be on IE11 to use the Google Map view and it helps if you are using Windows 8 or higher.