Custom override variables missing from onboard screen


When we create an AP Group with custom overrides, it doesnt seem to show the custom fields in the onboard settings window.

Normally we onboard an R200 device, click the edit button, give it a name, location, and then select the ap group template, fill in the custom override fields then click save, approve.

So we need to set the variables before we approve the onboarding.

Our old templates still do this, but new ones wont. Does anyone know why?

If we approve the device, have the customer plug it in, let it do its initial onboard, we can then edit the variables and save/push the config out but that means we have to wait for each customer to plug their R200 in. We want to do it in bulk before the devices are approved and powered up.

Can anyone suggest how we might get those options back?


I was able to reproduce this issue and have reported it to our development team.

As a temporary work around until we get this fixed you set the User-Defined Override values after onboarding from the configuration screens.

  1. Navigate to Configure -> Configure devices.
  2. Select the device you which to update from the left-hand tree or find it in the table.  Be sure to select cnPilot Home (R-series) in the Device Type drop down if you use the table.
  3. Select an AP Group from the drop down.
  4. The User-Defined Overrides section will appear at the bottom of the screen if you selected the device from the tree.
  5. From the table you can edit user defined overrides by clicking the gear icon at the far right end of the table.
  6. Save your changes and Apply the configuration to the device.  Select the "Start Job Now" option to immediately apply the AP Group to the device.
1 Like

Hey thanks Jordan - I look forward to it being fixed.

I am selling the concept to another ISP and so it was rather embarassing when I proclaimed how simple it is and found I couldnt make it work for them.

We're sorry you ran into this issue.

We expect to have the fix for this included in the next release.

Any luck with this? 

It loosk like there has been another release and now our existing profile/apgroup is missing its fields.. 

Can you clarify on what you mean by "missing its fields"?  Have you refreshed your browser after the update?

Yes now only one of our older profiles shows the fields - not the one we use every day. 

I have 100 R200 routers sitting in boxes here that I cant deploy. 

Please invite me (jordan.stipati) to your account via the Adminstrators -> Invite Cambium Support.  I will take a closer look at your account to make sure I understand the situation and check if the data is proper on the servers.

To clarify

- Old version, both our profiles worked

- New Version, only our old version profiles worked, new profiles that we made stopped showing custom fields

- New latest version, only one of our original profiles works

Trying this in firefox and opera

1 Like

Looks like i figured it out

The country field was blank in the APGroup template so have changed it to USA and it started working - perhaps this was lost or was never asked for in the version when the profile was created. 

1 Like

Glad you got it working!  Please let us know if you run into any other issues.