Device out of sync : Configuration failed: Specified template is not valid JSON

I’m using cnMaestro Cloud to manage 3x e400 access points. All on recommended software (4.2.2.1-r3) and same Wifi AP group. I’m trying to update the group config using cnMaestro cloud UI and push to e400s (Monitor and Manage > Wifi AP Groups > group name > Configuration > Radio > changes > Save) but sync is failing with:

“Configuration failed: Specified template is not valid JSON”

Have never seen this issue before. Haven’t made any manual JSON/ other code changes to template, just changing options in UI and hitting save . Not sure what is causing problem and cannot find how to download the cloud/pushed config in JSON to manually review for problems. Any advice?

Update: Have found the JSON file (for anyone else looking: Configuration > AP Groups and WLANS > AP group name > Export (box with up arrow)).

However running the JSON file through a linter (JSONLint) says code is valid. So now even less sure why the config is failing due to “Specified template is not valid JSON”.

1 Like

Maybe because some functionality is not supported by the e400?
Why use Jsons when you can sync by group?

@farrinm, please send the exported AP Group and attached WLANs to jordan.stipati [.at.] cambiumnetworks.com. I’ll see if I can reproduce this locally. Something went wrong when constructing the final configuration file. Do have overrides set for devices failing with this error?

@PFR, the underlying format of AP Groups is JSON in this case.

Thanks Jordan. No overrides should be in place. Will forward you the config files. Thanks for your help.

1 Like

All resolved now, but for anyone else that finds this thread, the new config was perfectly valid JSON, but something in the new config and the existing config really didn’t like each other Ultimately managed to resolve this by applything the config file directly to the AP after which it would happily sync again. I also tried a factory reset (which helped one AP but not the other). But for whatever reason, the error message stubbornly stayed as invalid JSON.

Check one think more.
Upgrade to 6.4.1 than downgrade to 4.2.2.1 and check sync again.

Hi PFR, in reply of your question in other topic… i am testing the ver6.5r15 on e600 to try resolve this problem “Configuration failed: Specified template is not valid JSON”, i think this was broken on the upgrade to the version 4.2.2.1 you are recommending…
I go try to downgrade again to that version and see if is solved.
Thanks and regards!
Alessio

Hi guys! i found the solution… in an upgrade or downgrade(i don´t know specificly in what version), the APs lost the DNS settings and stay bad configurated the DNS servers of each one to 127.0.0.1 in primary DNS server.
The solution is Override and setting to the corrects DNS servers and boila!

Synced and configurated!

Regards!
Alessio

1 Like