DHCP pool-problem with modem

is there any way to create DHCP pool without assigning it to any VLAN?
The problem is the e510s is connected to the modem in network, and I want it to run DHCP server for WLAN at The main modem doesn’t support VLANs, and there is a bug- when You try to connect to e510, you get absolutely no address at all. Tried the same config with another modem that supports VLANs, and everything works just fine.
Vlan1- dhcp client
vlan2- dhcp pool
WLAN-tag 2

Yeah, it is configured this way, VLAN 2 because VLAN ID–2.

Can you export config from e510 and paste here?

Yeah, of course:

wireless wlan 1
ssid Test
no shutdown
vlan 2
band both
dtim-interval 1
max-associated-client 256
client-isolation dynamic
client-isolation dynamic gateway-probe-interval 60
client-cache cnMaestro
network-policy-id 0
mac-authentication policy deny
passpoint interworking access-network-type private
guest-access portal-mode cnMaestro Test
interface eth 1
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 1,2
speed auto
duplex full
interface vlan 1
ip address zeroconf
management-access wired
ip dhcp request-option-all
ipv6 request-option-all
ipv6 address autoconfig
ip address dhcp
interface vlan 2
ip nat inside
management-access wired
ipv6 address autoconfig
ip address
ip dhcp pool 1
lease 1 0 0

Please try with this;
switchport trunk allowed vlan 1,2
and put
switchport trunk allowed vlan 2

Leave vlan1 as native

1 Like
  • Share output of “show dhcp-pool 1”

If it show “Down”, please change address range from -

1 Like

Done, after that status still down.
What’s weird, I’ve connected e410 to the same modem and applied the same config, and his DHCP pool is “down”, but e501 is now “up”. When I unplug e410, the e501 pool remains up… So that’s kind of a solution…
If I wish to have e410 and e510s connected to the same modem, they wouldn’t roam with cnmaestro, and I have to create 2 different pools?

Problem solved, updated software to 4.2 from on e501, and everything works just fine…
One more question, just to not create a new topic… Can I perform speedtest on the device?

  • WiPerf is tool supported by cnMaestro and cnPilot devices.

  • Speed can be tested to and fro between AP and cnMaestro.

  • FYI, This is cnMaestro-X feature.

1 Like

Thanks a lot, I know all now, You can close the case
Thanks again!

1 Like


btw., isn’t it left as native anyway?