Downloaded ePMP1000 software on to ePMP 1000 Hotspot

I worked to fast and made the mistake of only seeing the ePMP 1000 software section and flashed it onto my new ePMP 1000 Hotspot.  Now it is showing the LEDs scanning like it is a SM looking for an AP and it is not picking up a DHCP IP address.  I can't get into it now and holding the reset button in for 10 seconds didn't do the trick.  Did I break it?

Can you please let us know which ePMP version you downgraded to ?

ePMP Non GPS v2.6.  This was meant for the ePMP 1000 and I have the ePMP 1000 Hotspot.  The system allowed me to do it.  It was a mistake.  Should have upgraded to ePMP 1000 Hotspot 1.6.1 -r3

Okay.  It is morning and I figured it out.  I used the default IP of and was able to get into the radio and install the correct software.  All is good.

Thanks for the update, glad to hear all is well.

Changing firmware between the hotspot version and PMP version of ePMP is supported. One caveat is the ePMP version should be 2.4 or newer.

Let say I have ePMP 1000 connectorized 5GHz

Can I reflashed with ePMP 1000 Hotspot firmware

@nbctcp wrote:

Let say I have ePMP 1000 connectorized 5GHz

Can I reflashed with ePMP 1000 Hotspot firmware

yes the 5GHz connectorized version can also be reflashed to the Hotspot firmware. 

1 Like

I just brick my ePMP 1000 Hotspot 2.4GHz because upgrading from fw 3.3.1 to ePMP-NonGPS_Synced-v3.5.5.tar.gz

Now I need to reflash with tftp

My ePMP Hotspot 1000 2.4GHz really brick after upgrading from fw ver 3.3.1 to 3.5.5

Try reflash using above link


-install tftp server

-download and extract firmware.bin from 3.3.1.tar.gz and put it into tftp-root

-set my pc ip to

-run tftp server with nic ip

-connect ethernet cable from Power Adapter LAN to my pc

-plug POE ethernet cable

-ePMP 1000 on but no progress bar on TFTP server

-try factory reset but still hang (led become amber and green)

How to solve this?


Hi nbctcp,

Last software released for ePMP1000 Hotspot is 3.3.1.

Please let me know from where you were able to download 3.5.5 version.

I am successfully upgrade to Subscribed Module 3.5.5 by accessing

So now my ePMP 1000 Hotspot become SM

but I can't downgrade it to 3.3.1 Hotspot ePMP1000-Hotspot-3.3.1-r1.tar.gz

MD5 ea6090c7e3467f6325c89d062bc5be9e

It said "Digital Signature check failed"

I try download 3x times but still the same error.

How to fix

The reason I upgrade because of these

1. vulnerability in ePMP 1000

2. since this thread said, I can convert ePMP 1000 connectorized to hotspot.
I assume I can do vice versa

3. There is a procedure to recover in case of corrupted

But none said, I can't downgrade from 3.5.5 to 3.3.1

3.5.5 downloaded from here

Whats next action?

1. if you give proper steps to downgrade. I can do myself

2. otherwise I'll RMA



Here how I fixed

Downgrade first using old firmware ePMP-NonGPS_Synced-v3.2.2.tar.gz

then upgrade to ePMP1000-Hotspot-3.3.1-r1.tar.gz

This tips being told me by Abdi Cambium Indonesia

just pour avoir le  firmware cambium epmp 1000

Is there any particular version of standard firmware that needs to be in the ePMP-1000 radio before flashing it with Hotspot firmware.

I have been trying for a hour to get the 2 Ghz ePMP radio to take the Hotspot firmware, with no luck,

Tried several versions of firmware in the stock 2 Ghz ePMP radio such as 2.4, 2.5, 3.1, 3.56 and cannot get the radio to take the Hotspot firmware.

Finally got the ePMP1000 2 Ghz to accept the Hotspot firmware. Had to install standard ePMP-1000 firmware Version 2.5 (which is an old version of standard firmware) first - then install the Hotspot firmware.